Messing around with a bsp brush causes a crash

We apologize for the inconvenience.
Please send this crash report to help improve our software.


This is the third time i have seen this in less than 5 minutes. All i was doing was messing around with a bsp brush.

Hi ,

Can you provide more information on exactly what is happening when you are getting the crash? Listing the steps that happens when you get the crash as well.

When you are using the brush, is it happening when you drag the brush into the editor window? Is it happening when you are adjusting the brush in the details panel or using the scale tool in the editor window?

Is this happening in the current level you are working on only or is it happening in any new maps you are working on as well?

Thanks for any information you can get me!

It would seem to be only the level i am currently working on. As i have not had this issue until i tried following the digital tutors video that was recently released. The steps are as followed: 1. I duplicated the brush i had placed with crtl-w, 2. i went to change the brush in the place menu to subtract, to change the brush i had duplicated(i did not realize this was not the correct way of doing this.) 3. I went into edit mode then selected the vertices, it lagged for about 2 minutes until it finally crashed.

I hope this helps. - Ron

I have loaded up a blank level and attempted to recreated the BSP crash issue you’ve listed but am not getting the same results you are with the crash.

Have you tried doing this in a new/different level with the same result?
If you open the level back up is it doing the same thing everytime?
Also, is it performing properly up until you use the geometry editing tool to move the brush vertices?

If at all possible please also provide the following information:

Can you detail your machine specs and OS?

Can you provide us with the .LOG and .DMP files from your [project]\Saved\Logs folder.

Additionally, you can please send us the CrashReportClient.log file located in C:\Program Files\Unreal Engine\4.0\Engine\Programs\CrashReportClient\Saved\Logs.

Thanks for taking the time to compile this and get back to us!

I have not been able to recreate the problem. I deleted the old level i was using. It was performing great all the way up to using the edit tools.

Processor: amd fx 8320
Ram: 8 gigs ddr3 (1600 mhz - not sure)
Graphics card: Amd Radeon hd 7850
Os: windows 8.1

actually decided to compress the file to see if i could send it here you go.
link text

Thank you for taking the time to get back to me with all this information!

I just want to get a little bit more information.

In your repro steps and you were creating the brush and then creating the subtractive brush, was it only crashing when you went into editing the vertices using the geometry brush?

Thanks again!

Yep. It would give kind of a lag when I selected 2 vertices. Then I couldn’t unselect them. I tried going back to place to get out of edit mode to no avail finally it would crash and ask me if I wanted to send info to epics server. Which I clicked yes. I tried three times, got the same crash from what I believe was the same basics steps till I realized I needed to use the tool bar to the right to get everything to work.

Hi ,

This is a known issue that is currently being assessed by the development staff. Thank you for your report!