Download

Meshes won't snap to grid in blueprints

I’m trying to make a door that slides open. I created a new blue print and dropped a static mesh but when I move the static mesh it seems to move in random amounts.

Hi sanford87,

If you look at the viewport toolbar in the viewport you are looking in, there should be a button that looks like a 4x4 grid, if it is orange, grid snapping is enabled, if it is white, grid snapping is not enabled. You can also set the size of the grid snap in the drop down menu under the number to the right of the enable grid snapping button.

Hope this helps!
Adam

I appreciate the response but the grid locking is activated. This isn’t the main game viewport(I don’t know if that’s important) things snap perfectly in there. It’s the components viewport when making a blueprint that they go crazy.

I have the same problem. https://i.imgur.com/492qHcs.png My mesh won’t snap correctly to the grid in a Blueprint Class.