Meshes black after lighting build

Hi, I’ve imported a very simple, blocky site masterplan as an early UE test.

After I hit Build, all my imported meshes turn black, and I can’t find a way to get them back to their imported colour. I’ve searched forums and tried the recommended fix: their Lightmap Coordinate Indexes are all set to 1, and the light map resolution is 512 (I’ve even tried larger). The only thing that seems to fix them is to change them from Static Mesh to Movable, but I understand this comes with a performance overhead.

They’re exported from ArchiCAD via FBX file type. ArchiCAD doesn’t have any UV options, so I can’t do anything before export. I’ve left the ‘Generate Lightmpa UVs’ option ticked when importing, as removing it seemed to force the meshes’ Lightmap Coordinate Indexes to fix at 0.

Any suggestions? Is the model scale an issue? It’s essentially real size, so some of the blocks are quite large…



EDIT: I’ve found a fix - the exported model didn’t have any materials assigned that used texture mapping. Once I’d applied a UV-mapped material before exporting, it was fine. No idea if that’s the recommended fix, but it seems to make sense!