Download

Meshes adding A LOT more polys than what I imported.

Hi! So basically I have a mesh that imported. Now when I made the mesh in Blender it was only like 2,500 polys, imported and it was 500,000+ polys. Also why every single thing I make visible from only certain angles? It’s fine in blender but if I view from say inside the mesh than I can’t see it.

Materials in UE4 are not two sided unless you specify in the material panel that it should be a two sided material. If it’s one sided then normals that are facing away from the camera won’t render.

In terms of the polycount…are you certain you unchecked the box that exports your whole scene from blender and not just the selected object? Bear in mind also that if your model in blender has quads they will be turned into tris when imported to UE4 Edge splits and uv splits will also up the polycount a little but it shouldn’t be as massive as you are seeing.

thank you good sir!

Also you shouldn’t use a 2 sided material for everything, if only part of a model is one sided, you can duplicate just those polygons in blend and invert them. Blender has a back face culling option if you want to see how it will look in UE4. I don’t use Blender, but from a good search, this is how you do it.

Sounds like it applied a subsurf modifier on export. One possibility anyway.