Mesh With Multiple Material IDs Not Importing Correctly in 4.15

Hello I’m trying to import a mesh that has multiple material IDs. In 4.14 I would get the obj and multiple materials to work with. In 4.15 I do not get the same results. It splits my obj into multiple meshes corresponding to the different material IDs and I only get 1 material.

Thanks for any help you can offer.

Just tested Multi material ID on Blender. Engine 4.15.
Works correctly. (exported as FBX of course) can you provide info on what modeling software you are using ?

This is happening to me… In 4.14 I used to import my FBX and it would import the single object with all materials and textures, now it splits the same object in over 1000 parts. I tried every importing option and no luck so far.

I haven’t tried fbx format but it seems to not work for cosmicman either and he’s using fbx. I just hope it works in 4.16 haha.

Just tested blender fbx and it works fine though I’ve been using 3dcoat and obj format.

Ok I found the solution… kinda. I had to import into blender and merge all my meshes and it kept my material ids. The weird part is in 4.14 it just imported as one mesh to begin with… Oh well.

This is unfortunate, there should be an option to let you import as a single mesh, and if there is I can’t find it.

it work fine, but in 4.14.2 it will crash the editor while import multiple material mesh, should be take noticed

I managed to find the mesh combiner and that took care of my issues.