Mesh transforms down slightly when simulating physics in PhAT

Hello I have tried to reach out on a bunch of different support forums, reddit, and discord, but no one has been able to help me with this issue, so I would really appreciate any help.

Here is a video of the problem:

So I created a simple fern thing in blender. I added an armature (one root bone at the center and 8 bones directly under the root in the heirarchy… one for each leaf). I used weight painting to make sure every bone only impacts one particular leaf. Then I imported into to UE4 as a skeletal mesh and created this physics asset. I have a kinematic sphere attached to the root and a simulated capsule with an angular motor attached to every other bone. The strangest thing though… whenever I press simulate, the entire plant moves down except one leaf (the leaf with bone01 (not the root))! I am racking my brain here. All of the capsules attached to the leaves have the EXACT SAME settings and I cannot find anything in blender that would explain why this particular leaf doesn’t slide down but the rest do. Note that gravity is disabled in all physics settings.

Now things get even weirder. If I were to just put on two different physics assets on two separate leaves, the first bone in the hierarchy I put it on stays in place and the other leaf slides down, regardless of what bones have physics. Does anyone know what the issue might be here? I really need the physics asset to mimic the static mesh I am going to create so I can swap them out, but the physics asset having this problem of moving down prevents me from doing that well. Also, note that all of the physics interactions work how I would expect them to otherwise.

Thanks for reading and I would appreciate any help on this. UE4 version 4.21.1 and blender 2.8 if that helps.

UPDATE: I created another even more simplistic plant made of three rectangular prisms and I am having the same issue. Has anyone had this issue before? It must be export / important related. Also, it appears that when setting the root body to kinematic, the issue shows itself, but when the root body is simulated, the issue goes away. Of course, I need the root body to remain in its place otherwise the plant will just fly through the air but perhaps that information might help.

Okay I have been working and searching for an answer to this problem for about fifteen hours and I decided to just go down the rabbit hole of the related questions sidebar. After some more searching and trying things, I finally found a thread that didn’t turn up during my searches before but it helped!

If anyone else happens to stumble onto this problem, the solution at the above thread worked for me.