Download

Mesh still collides with the player despite setting the collision channel to ignore pawn

it looks like the only way i can get this to work is to set it from code and not the editor which is weird does anybody know why?

this is what i do in the editor and doesn’t work.

but it works if i do it from the code?
Annotation 2021-08-12 184322

Are we editing a blueprint or are we talking about an instance of an actor in the world? If you drag an actor into the scene, you can override its settings for each instance individually. From now on they will differ from the defaults. That’s why overriding it will script will always work.

As in:

The blueprint is on the left, the instance on the right. You can change the settings of the blueprint and compile it but the instance has overridden it, so it will stay as is.

Perhaps that’s it. Or we’ve got a different scenario at hand?

nah it’s a blueprint and this is a parent actor cuz i want all the child to be affected as well. the childs are also spawned at runtime so there’s no way i can override them in the editor.

Not sure what you’re tinkering with on your end, but this has always worked and still works on my end - at least up to v4.25. Not that it helps you much, but just sayin’

this is a parent actor cuz i want all the child to be affected as well

Not sure what to say :|, sorry:

can u actually test this in game cuz in the child actor i see that the collision is the same as the parent but at run time it still collides with the player.

Sure thing:

  • ignoring pawn

  • blocking pawn

I changed this settings in the Parent.


My gut instinct says you’re looking for a culprit in the wrong place. It’s something else / somewhere else.

You can also test it yourself. :smiley:

well, I’ve been testing this ever since i started my project :grinning:

I’m also using 4.26.2 so I was wondering maybe that’s the problem but apparently not…

Try deleting the blueprint instance in the scene, and then adding it again.