Mesh not "glued" together with "Set Master Pose Component" when Engine Scalability Settings is set to low?

My character is set up using a base mesh and several “slave” meshes for the bodyparts. They are all “glued” together with the “Set Master Pose Component”, but when I turn the Engine Scalability Settings to low, there are holes in the mesh.

Scalability Settings Epic:

Scalability Settings Low:

Hi , I have isolated the scalability slider to be the “View distance”, when I turn it down to medium the holes in the mesh appear. I have tried to remove LODs from the mesh with no effect.

Hi Number47,

This sounds more like an LOD issue than anything to do with SetMasterPoseComponent. You can try just playing the same animation on both assets at the same time and modifying scalability again.

However, can you try modifying each scalability setting one at a time to see which one is causing this?

Can you send me the assets that you’re using? Those white lines could also be texture seams and I’d just like to take a look at it myself.

You can PM me a link on the forums. Please respond here after messaging me.

Hi , I am using the “Customisable Medieval Knight” from the marketplace as is. Customisable Medieval Knight in Characters - UE Marketplace

But I can easily send it to you.
Best Anders

Hey Number47,

try to enable on all your slave skeletal components the option ‘UseAttachParentBound’. You can find it under the ‘Rendering’ tab.

Hey Number47,

While it may be on the marketplace, we don’t leave marketplace content readily available for all in the company. You can send it to me on the forums for debugging purposes.

However, if 's suggestion works, no need to send anything.

Hi , unfortunately it did not work.

Hi , I have PM’ed you a link to the asset.

Hey Number47,

These files don’t appear to work when brought into a third person project. Can you upload the full project as well as your fbx files? To reduce file size, you cand delete the Saved and Intermediate folders. Sorry for any confusion.

The CharacterBP derives from a non-existent parant class for me.

Hey, can I ask how you’re creating your skeletal mesh LODs? If you preview the idle animation on the torso at LOD level 3, it deforms inward on some of the edges. The View Distance is just causing the meshes to go to a low LOD level.

Anyways, it appears to be a skinning issue on some of your LOD levels. Can you investigate that and let me know what you find?

Hi , since this is a purchase from marketplace I have not made the asset so I don’t know how the LODs were made. I will contact the creator and ask him about it. Its not that this is gamebreaking since I am aiming for a more highend, I just wasn’t sure if it was a bug or not.

You’re going to have to take this up with the creator of the content. You can find their contact info in the Marketplace listing.

I have been in contact with the creator and he has created a fix for the LODs and will include it in an update to the marketplace, but he was wondering why the engine would swap in the lowest deatiled LOD when going to near view distance.

View distance has a direct affect on which LOD is in use

Hi, could you help me with my issue?
I have same setup (master mesh and few slaves), and i use set_master_pose_component to merge them, but i have few lods on each mesh and it doesn’t change lod in-game.
here my question