Mesh LOD levels do not respect collision settings

win 64, UE 4.9


1.Set up a LOD level on a mesh, uncheck “enable collision”
2 You will observe that the LOD0 collision is still used even on LOD1

Sample project: Dropbox - ColliderBug - Simplify your life

I added a LOD to the cubes in the scene, but they still use the LOD0 collision

Hi ,

Did you create the collision for LOD0 in a 3d modelling program or did you try to create it through the editor?

LOD0 has a box simplified collision, created in the UE4 editor.

My apologies, I mistyped. I intended to say LOD1, the rock.

I didn’t set any collision up on the rock at all, I am trying to create a situation where LOD1 doesn’t use collision at all. (“Use collision” is unchecked on LOD1)

Hi ,

I was able to reproduce this and have entered a bug report, UE-23799, to be assessed by the development staff. I discovered that the error is actually with the enable collision checkbox. It seems setting this to false does not currently disable collision on actors, and that the LOD is irrelevant for this error to occur.

Unfortunately at this time I do not have any reasonable workaround. It is possible to manually sett a distance and disable the collision via blueprints when you are a specific distance away by setting the collision channel appropriately.

, thank you for following up on this I appreciate it. Re: workaround, I’ve been handling it as you suggest and it works reasonably well for the time being.

Hi , hope you had a great holiday! Just checking in on the status of UE-23799. Many thanks.

Hi ,

This bug is still under assessment. Unfortunately, I do not have a timeframe of when this will be addressed.

Just checking in on UE-23799 - do you know if a fix has made it in to 4.11/4.10 for this?

Hi ,

I looked into 23799 and it appears this functionality is by design. The functionality works with collision meshes, however it is not supported for Generated Primitives (boxes, spheres, capsules, etc.)

That’s really not clear in the UI at all.


If the functionality works with collision meshes, what does it mean? How should I set up my LOD1 foliage mesh to have no collision? Should I make a custom collision mesh for the LOD1 mesh, or… ?

I can’t manage to cull foliage instance collision at greater distances and it causes a terrible performance drop, just like reported HERE.

That was never answered to my satisfaction either. I would like Epic to shed some light on how instanced meshes are meant to be used - as far as I can tell there’s no way to effectively manage colliders which is a huge issue.

Hi and ,

The process in 4.12 has changed for LODs, as such, the Enable Collision for LOD feature was disabled unless you specify a specific LOD for collision. Information on that can be found here.

The Enable Collision feature for each LOD is referring to Per-Poly collision. Foliage should have reduced collision shapes to alleviate some of the performance loss you are seeing. Grass should typically not have collision at all, as this will result in a signficant performance decrease. Instead, “collision” within grass objects should be faked within the material. You can find this information in the tooltip for Enable Collision.