Download

Mesh faces not visible

Capture1.PNG.jpg

I’ve imported a mesh to Unreal Engine but some of its face appear as if their normals are the wrong way out even though the normals are the right way out. Can please someone tell me what I am doing wrong here?

Face Orientation in Blender

To assist determining which way a face might be pointing, especially if Backface Culling](Backface Culling – Blender Knowledgebase) is not disabled in Viewport Overlays or Viewport Shading options (depending on the viewport display mode) or a given materials Settings properties, Blender 2.8+ includes an option to colour tint faces based on their orientation, RED for surfaces pointing inwards and BLUE for those pointing outwards, making it much easier to see at a glance what’s going on, which then allows for individual faces to be flipped or recalculated as needed. To use, click the Overlays button upper-right of the 3D View and from the menu select Face OrientationOverlays » Face Orientation. Everything will immediately tint blue/red based on their orientation. To disable, repeat, select Overlays » Face Orientation.

Thank you. That was a very helpful, but I’m afraid I’m still not sure why the faces are not visible in Unreal Engine.

It’s a bit strange. Have you tried in Blender to make a copy of your object and export that copy?
Have you tried marking on the object’s material instance in UE4 in “Override Materials” Two sided?
It is what I would try at first and see what happens.