Mesh export hangs at 40%

Exporting a 60M triangle mesh with textures usually takes a few minutes on my system, but today the progress is stubbornly still 0% after 1 hour.

I tried again to export a mesh with per-vertex color; it’s stalled at 40%.  Note:  I realize that RC quantizes its thermometer bar output and so reporting 0% or 40% for long periods doesn’t mean it’s not working.  However, what worries me is the lack of progress over total wall time.

Does this sound familiar to anyone?

There are a few discussions such as this post which suggest similar results, but no response from RC except the distinctly unhelpful ‘it always works’.  Which, of course, is pretty glib.

In fairness I’ve not had problems exporting before.

Hi Kevin,

you have my sympathies! After a brief period of more activitiy a few weeks ago the forum now seems to be almost deserted, especially by devs.

I am sure you have tried everything imaginable, but just to be sure:

Have you tried (severe) simplifying / exporting only a small part of the model / exporting with no colour / selecting different output formats / playing with preserve model parts?

Does this occur with the newest version 300 9?

Best, Götz

Thanks Götz for a characteristically fast and empathetic reply!  :wink:

Yes, this was with the brand new 3009 build, though I have no reason to think that has anything to do with it.

As you guessed, I did try a few variants, and did hit on settings that worked…

Interesting, I was able to export the meshes only when vertex normals were ON and camera export OFF.  If I reverse the two (normals OFF, cameras ON), the export fails.

Very strange!

Anyhow, for the moment I’m fine and I thank you again for checking in.  I hope the discussion board begins to heat up again in the near future to make it more interesting for you…

Thank you also Kevin, equally typical!  :smiley:

There seems to be another export problem with texture files - so I don’t think it’s too far a fetch to suspect a new bug in the export department.

Your very concise analysis points (in my layman view) also strongly towards a bug. I think it is worth a report!  :wink:

This is still an issue. Hangs at 40% everytime. I tried multiple models, multiple settings. This time I’m trying to export mesh as .xyz. If I end the program using task manager, it does write a file. It’s not a complete file. Missing large chunks of data. Running version


Hello Greg,

I tried to reproduce it on the same version but the model was exported correctly. What license of RC do you use?

On which drive are you saving the exported model? Could this drive cause the problems? Can you please try to export to another drive and in other file format if the problem persists?