Download

Mesh Collision generation issue

So for alot of my models I just use the Auto Generation Convex collision from within the Editor. For the most part this works really well with a good number of the models. But afew of my models have some issues.

Like the attached pic the auto generated collision mesh appears to be offset and below the actual model itself. Even just a auto generated box collision will be offset like this.

Now granted these objects are somewhat small in size and that appears to be the only ones that really have issues like this. Anyone else experience this? Any easy fix (scaling the models are not a option)…

Is this just a bug with the engine?

PossibleBug.jpg

5c9b624adddc8f804bbf87b4f7215b3db9241b0f.jpeg

I never experienced that, but it may be the model size yes. Try importing it with a bigger scale. Yours is very small.
There should be no issue with scaling it. If it appears too big in game you just drawscale it back down to what it was before.

Have you probably reimported the mesh? Because when you reimport something (so that the old mesh gets overwritten), the collision will stay

No this is a fresh import of the model. I am thinking it has something to do with the scale of the model itself. Somewhere along the way there is a bug with the collision appearing in the right location for small objects. Guess I am just going to have to import it at a larger scale and size it down from there, see if the same issue reappears or not.

Its only happening with the smaller this size and smaller models. 2x this size and above generate collision meshs that are good and fit the model.

Which 3d program do you use and whats your current workflow to create/import your mesh?

I use 3ds Max 2014 to create and export the mesh into a .fbx from there I just do a import of the mesh into UE4 I use the following settings on import.

Calculate Normals, Remove Degenerates, One Convex Hull Per UCX, Import Materials, Import Textures, OVerride FullName.

There are no LODs on the models as they are already fairly low poly count from the start. No scaling or anything from within the engine itself. No modeled collision so thats why I use the Auto tool within UE4 to generate the collision meshes. I have also tried having it generate just a 6DOP collision and it still appears offset from the model. And its only these smaller models that appear to have that happen on.

It is just strange that the collision generated is perfect to the model its just offset from the model is all. So it doesnt appear that it is having issues making the collision. Just where it seems to be placing the collision is all. I still think its just a bug somewhere along the collision placement lines.

I think I will try giving it a simple box collision within 3ds Max and see if after importing it and the collision if the same issue happens or not.

It seems to work when scaling up the models from 10x to 100x the size. Like with my smaller ships the collision is now fixed. But things smaller are still getting offset collision.

After looking at it even more. Its no so much that the collision is offset. The collision is appearing centered at 0,0,0 and the model itself is being offset from that. The models are modeled so that the model is centered at 0,0,0 but after being inported that appear offset from that location. But the collision that is generated is centered perfectly at 0,0,0

If that makes any sense at all.

Hi Toom,

When you are exporting your FBX from 3ds Max are you setting the scale to centimeters?

Also, if you have a mesh you could upload or create a simple one with the issue that you could upload I’d love to look into this and see if this is a bug or what the issue really is.

If/When you upload the mesh, could you include an exact step by step reproduction of the steps you use to get the scaling collision issue in UE4?

I’m not sure if you mentioned above or not, but have you tried using custom collision set up within 3Ds Max and importing that with you model rather than using UE4’s auto-generated convex hulls?
There’s a tutorial from 3DMotive about Custom Collison that is really well done to help you out if you’re not familiar.

I look forward to hearing from you!

Thanks!

Tim

After trouble shooting and then going through to reproduce the problem to post what I was doing, I found the issue. Kind of embarrassing error on my part. The models textures had a image hooked up to the world position offset. On the larger models the change was so small that you couldnt even notice it. But when your dealing with models that get very small the offset appeared much much greater due to them being small.

So there is no issue afterall. Just a error on my part.

Glad to hear, Toom!

Thanks for posting your solution!

Tim