Mesh bones visible?

So I decided to use (3D Studio Max 2013) simple pyramid meshes as bones when rigging and animating my mesh which used to work fine in UDK but it seems that in UE4 they import as editable polys and are visible in game. Is there something I need to do to get them to be flagged as bones and not visible in the editor or can you not use meshes as bones anymore?


No one has any ideas?

Hello TorQueMoD,

Yes you can use pyramid meshes as bones and import them.

Steps to follow:

  1. Export the pyramid editable poly as you would normally.

  2. Go into your content browser of the editor and click on import.

  3. Choose your mesh and check the box that says “Import as Skeletal.”

  1. Now click the import button and it will create a skeletal mesh of the asset you imported.

  2. Pull the mesh into your active viewport and under the “Rendering” section within the details panel check the box that says, “Actor Visible in Game.”

  1. Play in the Editor and the mesh will not be visible.

Thank you and I hope this helps!

Thanks for trying to help but this didn’t fix my problem. The bones are part of my entire mesh not separate so if I bring it into the viewport and chose Actor Hidden in Game, it hides the entire bird not just the bones. I think this would only work if the bones were separate from the model which they are not.

Also the bone positions are actually being moved as well when imported so they’re not in the correct location…

in 3Ds max the bones is inside the wing.

In this case you need to make sure they are not the same mesh because they need to be separate things when importing and exporting. The bones control the mesh, which means they cannot be all the same mesh.

I would suggest using the skeletal tool provided by the 3d application you are using to create your bone structure when binding it to your mesh. The avoids the issues of having to hide your bones within the editor.

Here is some great documentation all about skeletal rigging and the proper pipeline to creating, importing, and targeting the skeletal mesh so it animates correctly.


They’re not the same mesh…I’m using 3D Studio Max. I’ve rigged the character mesh to the bones using a skin modifier. But when I try to bring the skeleton into the editor window like you suggested it brings in the entire skeletal mesh and not the skeleton alone so I don’t get individual control over what parts I can hide. Its an all or nothing deal.

If they are not the same mesh be SURE to import them using the “Mesh” section settings correctly.


Import as Skeletal:
“Whether to import the incoming FBX as a skeletal object”

Import Mesh:
“Whether to import the mesh. Allows animation only import when importing a skeletal mesh.”

Skeleton to use for imported asset. When importing a mesh, leaving this as “None” will create a new skeleton. When import an animation this MUST be specific to import the asset."

You need to make sure these options are correctly chosen when importing your assets to have them assigned appropriately. It seems like you might be doing one of these out of order or importing them incorrectly which is why they are being combined or not assigned appropriately. If you have done all of these options correctly, and are still experiencing the problem let us know.


Thanks again for all the help. Here’s a video showing my process…

Since creating the video I noticed the checkbox for import timeline 0 as reference pose and this fixed the bone movement issue. They are still however visible in editor.

Hey ToQueMoD,

Would you be able to provide a test asset that is able to reproduce this issue so we can further investigate? It does not have to be anything complex, just a simple mesh with geometry as bones.

Oh yeah no worries… here’s the mesh I’m using…


I imported SK_Phoenix.FBX in 3DS MAX 2015 and export it with next setting:

  • For export use “Export”, not “Export Selected”
  • In FBX export dialog select preset “Media & Entertainment”
  • In “Include/Geometry” select “Smooth Grous”, in “Advanced Options/FBX File Format/Version” select “FBX 2013”, and “OK”
  • In UE4.5 import FBX, in dialog i am simply press “Import” button and get this

I’m doing exactly as you say and importing into 4.5 and still can see the bones.
Not sure what’s wrong but I’m clearly not getting the same results that you are using the same method.

Hey TorQueMoD,

I grabbed your asset and you will be happy to know it is literally just a check box you need to uncheck to hide your bones.

Follow these images to get the correct results:

Uncheck “Import Meshes in Bone Hierarchy”

What this settings says is, “If checked, meshes nested in Bone Hierarches will be imported instead of converted to bones.”

Final Product


OMG! Thank you Andrew! This finally solved my problem!