Download

Memory Leak in Movie Render Queue (Out of Video Memory ... ) ?

I keep getting the “Out of video memory trying to allocate a rendering resource. Make sure your video card has the minimum required memory” error message, however it should NOT be out of memory…

I’m working on a small cinematic project, and I would like to render one still frame. I share this project between my PC and my laptop, however, I am unable to render it on my laptop, even though it has pretty much the same config as my PC.

My PC has an i7 6700K, RTX 2060 Super, 32GB of RAM - and my laptop has Ryzen 9 4900HS, RTX 2060, 32GB of RAM.
They both have RTX 2060s, and 32GBs of RAM, there shouldn’t be much difference.

Yet, I get the “Out of video memory…” every time I try to use the Movie Render Queue on my laptop.

In the Task Manager, I can see all of the 32GB of RAM getting eaten up by UE4 when I hit render. I set the virtual memory, first to 32GB, then to 64GB, but didn’t help.

I then thought, maybe it’s because the laptop tries to use the integrated GPU, so I set everything to max performance, and to use the dedicated GPU (both in Win10, and in Nvidia Control panel) - didn’t help either.

I tried lowering the resolution, tried deleting a few objects, enabling-disabling console variables to lower the quaility - didn’t help either.

Nvidia drivers, laptop (Asus) drivers, Windows 10 itself - all is up to date - still nothing.

Yet, I can render the scene on my PC. I just copy-pasted the project folder to my laptop, but I can open it just fine, so I don’t think there should be any problem there…

Any ideas? Thanks!

1 Like

what if you use the tiling render from the movie render queue?
GPU drivers crash with long computations (TDR crash) | Substance 3D Painter what about these Tdr settings in registy?
https://www.youtube.com/watch?v=XBu0otF-CxA I’ve seen some info on that in this long video

1 Like

I have this issue too with latest version 4.62.2 /win10 and gpu drivers…
mine is on desktop though with RTX 2080ti and 64GB of RAM .

1 Like

Game developer here, enocunter same problem after updating last windows and nvidia drivers.

any fix to this problem yet? Still experiencing this today