Megascan Assets look very blury and not 8k resolution in UE5

Hey there,

I’ve got a problem with the megascan assets. All of my imported assets look very blury and not the resolution of 8k or smth.
I’ll send some pics so maybe anyone can help me.

I thank you


Try check, Project Settings → Texture Streaming → False

hey thank you for your quick answer.
I turned it off but with the same result.

Texel density is not pixel density. 8k doesn’t mean that the texture will always render sharp at 8k screen regardless of how close you get to it. It just means that the texture has 8k*8k pixel resolution. If you get too close to the object, it will still get blurry.

Texture resolution has nothing to do with screen resolution.

yeah thats true but not that blury and not at this angle.
you can see a lot of videos/tutorials out there where they get closer and got a much better quality.

This might have to do with your project scalability settings, make sure to set those to Epic or Cinematic. Also, scalability settings can be customized per project according to your hardware by editing or adding a “DefaultScalability.ini” to your config folder. I’m suspecting the texture streaming pool size is low. In that .ini file, you should be able to increase your texture streaming pool size according to your hardware. Each scalability setting (cinematic, epic, high, etc) can have its own pool size assignment. This is an example of the formatting of those settings inside the .ini file, it increases the higher quality settings to 3gigabytes, as well as the others: