MediaPlayer doesn't work

I installed Lyra sample and VirtualStudio sample.
VirtualStudio sample works just fine.
So first, I tried migrate the “WallMediaPlayer” file in VirtualStudio to Lyra.
Migration completed successfully, but the video won’t came out.
When I hit the play button, I can hear sounds but no images on it.
So I googled it. How to make MediaPlayer without using sample files.
I tried and failed only in Lyra sample. In VirtualStudio sample, they works fine too.
So I guess the MediaPlayer requires special project settings or plugins.
What is it?

Check the plugins enabled on the projects that work. Doing a search for media is probably best to see what’s enabled and not enabled.

Well, I’ve installed all the plugins in VirtualStudio sample.
And now, I’m pretty sure this is a bug in unreal engine.

Media Player worked in 4.26, it didn’t work in 4.27.0. Then in 4.27.1+, it worked again.
And then it stopped working in ue5 alpha and it never worked up to this point (as far as I tried).

In UE5, if you switch Default RHI (in project settings) on Default (dx11), the media player works. When it is set to dx12, it doesn’t.

It seems like right now (and god knows for how long), we have to choose between using a media player OR lumen.

Annoying :slight_smile:

1 Like

Thank you so much for this answer! :grinning: I was stuck but now I can move on.
So now we just have to wait for next update with our fingers crossed for lumen.