Download

Media Textures not working after packaged for windows

Hi guys,

I’m trying to troubleshoot an issue with media textures. In 4.8, they don’t seem to want to play after I’ve packaged my game. The movies are in the content/movies folder and I’ve setup the materials to be unlit. The stream mode is set to “FromURL” because trying to use “FromMemory” causes the executable to crash after I run it. I’ve noticed the path to the .wmv’s is relative which is what we want anyway I would assume.

Doing some digging around the forums I’ve found some people have had issues with Android but nothing windows related. Does anyone know what I’ve done wrong or missed?

Try to setup material as “default lit” and link the texture both to “base color” and “emissive color” 8be2f4e842829c5b2a684e3042e2bcebf765b22f.gif

That didn’t seem to fix anything unfortunately.

I made a test on the fly and you are right, looks like the video on texture not start, i will continue make some test, if i will find some solution i will post here.

Seems i solved here in this way:

  1. Open the level blueprint
  2. Create a new “Media Player” variable
  3. Compile the level blueprint
  4. In your Media Player variable details you have to set you your media player asset into “Default Value -> Media Player Asset”
  5. Drag “and get” your variable into blueprint
  6. Drag from your “output socket (probably not the right name, sorry)” of the variable and search “Play”
  7. Link the “Play” node to the “Event BeginPlay” node.

Here how is my level blueprint

7ea94098841ff76f8a2232f7784aeb7e10ae532d.png

Tell me if it work for you.

EDIT:

Now i remember i have done it two weeks ago :smiley:

That worked! Thank you for the help kind sir.

I’m surprised this isn’t in the documentation for media textures. I just assumed I wouldn’t have to tell the texture to play since it worked fine when testing in the editor.

The documentation about Media Framework is outdated, indeed if you notice in the doc image we have an “autoplay” checkbox

AJSt1eE.png

but in the recent releases of the engine we don’t have that checkbox and we have to autoplay the media textures/media player “manually” into level blueprint.

I know Media Framework is still work in progress but i hope Epic will update the documentation.

Hello,
I’m using Unreal version 4.3 and 4.4 and I have the same issue you had but the solution above didn’t work.
Video texture plays well in the editor with hit play button but when I package, it doesn’t play at all.

Do you have other solutions?

Thanks,