Media texture not showing

Hy! We have a media texture that is a working clock with the seconds passing, like in the screenshot attached. While in the engine and on playing the level the video is working, when we play the “Movie” button in Matinee, the texture dissapears. Does anybody knows how can we solve this problem? Thank you !

Hey razanus,

Try creating a new folder called, “Movies” and placing your clock video within this folder. Then package your project, be sure however you are calling the media player movie to play is on start and the playback rate is set to 1.0.

Let me know once you have attempted this and are still having issues.

Thank you,

Andrew Hurley

Sorry but it is still not working. Also, I want to mention that I do not need to package my project, but only to record some frames inside the matinee by clicking on the “movie” button, as in the screenshot. Thank you anyway for your answer.

Hey razanus,

Would you mind providing me with some screenshots of how you are calling your Media Player Asset to playback through blueprints?

As an example of how I have my scene set up, you can create some blueprint logic so that on ‘Event Begin Play’ you can set the play rate of your media asset video. This way, when you press the movie button and your project begins playing, your media player asset will be playing as well.

Thank you,

Andrew Hurley

Sorry for answering so late. I left the office, but in two hours i will be back and will let you know if I can do what you say. Thank you very much!

Ok, 6 hours later, I am at the office. I am not using any blueprin to record the movie. Could you give me some hint on how to do that? Basically I have to setup that “On event begin play”, my “Media Player Texture” to start playing. But I do not know how to bring inside my Level Blueprint the Media Texture. Thank you again, and sorry for being so noobish at blueprints!

Hey razanus,

If you would like to achieve this option through the Level Blueprint using the Event Begin Play, you are going to want to create a new Media Player Asset variable.

Event Begin Play - Media Player Asset

Use the image above as a guide on how to set up your Media Player to play from Event Begin Play. Simply open your Level Blueprint and create a new Media Player Reference variable type. After you create this variable, compile your blueprint and select the media player asset from the content browser you wish to play.

Create a get reference to this variable by dragging it into your even graph. Connect this get reference to the Target input of the ‘Set Rate’ node. This will allow your Media Player Asset to play at 1.0 playback speed when you press play.

If you have other questions or need additional assistance let me know.


Andrew Hurley

Hi Andrew, I have done all of the above and I have had no luck in getting a video to play in a Build…Its just black… Works fine in viewer or PIE but not standalone or final Build. The video file I have tried multiple file sizes down to 1280x720 and various container types such as mp4 (using both h264 and mpg4) and wmv. I have used 4.11.2 and 4.12 preview3

any suggestions at this point I have no idea what else to do

I would also try the .avi video format. You could try providing me with your sample video you are experiencing issues with, and I can test it on my end.

Also, are you working on a Mac or on a PC?


Andrew Hurley

Hi Andrew, thanks for getting back to me. I am on a PC (two of them totally different) avi file was no luck and seem to have the same problem where when packaged or in standalone it is black… the file is very large so I hope a dropbox link is ok? For testing its just the kite demo downloaded from youtube and converted in AfterEffects to a .avi file. In the link is also the basic first person demo scene setup with what I was trying. Not sure where to go or what to try.

ps. I don’t know if this has to with anything but every time the media texture playspeed defaults back to 0 when set to 1

So I will say, the video file is 2.7 GB compressed, which is a rather large file. This could be part of the issue, as the Media Player does not handle large files like this super well at the moment.

Have you also made sure your movie file is in the folder labeled ‘Movies’ within your content browser?

What Packaging settings are you using as well?

The Playrate at 0.0 now is the new default as it used to be everytime you load the project and open the media player asset, it would play the video which was causing some issues and users projects to crash. I am unable to download the video as it is too large. I would try another video to see if it is the video or the media player asset itself.


Andrew Hurley

Hi Andrew,

Sorry about the file size it was the project zipped up so you could see first hand if there was any mistakes I was making. The files were indeed in the Content/Movies folder

My Solution for 4.11.2 (still no luck with 4.12 p3/p4 but that’s is understandable) after what seems like days of going back and forth with this issue is that the final builds packaged exe file must be run as administrator. I am admin of my computer and everything is allowed to run/permissions are allowed for unreal to run but I must right click and choose Run as Administrator and voila movie plays instead of black.

Wow, that is an interesting workaround that I will be sure to forward to others experiencing the issue. As long as you have it resolved that is the important thing at the moment.

Esti roman? :slight_smile:

@Andrew Hurley thanks a million it solved my problem of the video rendering super fast,

- YouTube the result,only want to know how to make resolution better