Media Texture black in Media Player (WmfMedia)

I seem to have issue with the video codec in unreal. I tried several mp4 video files they all show up black in the media player (screenshot) while sound works fine. Video is in Content/Movies
I tried serval playback options and WmfMedia options in the Project settings - nothing helps


I’m having the same issue.

Hi, my friend. I just installed the Electra Plugin and it worked.

Basically, follow the same principle you use to add an MP4 video.

Then, install the Electra Plugin and it works.


Thank you helped me a lot

1 Like

Thank you! Videos work with electra player enabled. The problem is only electra player seem to have way less capabilities. (see screen shot)

Is there currently a way to get the WmfMedia Player to work (under Windows)?

Is the problem with WmfMP a bug; something that will be fixed at a certain point? Or will the Electra Player be extended in the future? Would be nice to hear something about the strategy for video playback in unreal 5

also the BP seek component doesn’t seem to work with Electra although its stated that it should


Hey! I tried this but it doesn’t work for a live webcam, only for a video. Do you know how I can get it working for a live camera?

@data_morphana Please mark that as the answer, since it solves the issue.

I can confirm that it worked, just enabled Electra plugin, restarted the engine and now it’s working completely fine.

@data_morphana Please mark that as the answer, since it solves the issue.

how does that work technically, i’m missing the button somehow…

There are two way to let WmfMedia sound. One way is set the Native Audio Out, Another way is Adding a Media Sound Component and set its MediaPlayer. You can’t use both, otherwise, the video frame will be black (actually freeze)。It looks like a traffic jam. :sweat_smile: