Media Player cannot use online url?

I tried to put the source of the video as an url online but it’s not playing. Does the media player only work with the local downloaded media?
These are the examples:

YouTube is not supported. The other two links work fine for me with both WmfMedia and VlcMedia. What platform are you on? I tested on Windows.

On windows but I think I figure the problem out. The streaming I have has a “.” in it. The media player module then treats everything after that as a file extension instead of a uri. I modify the code of media player and it plays now.

I checked in a fix for the extension filter. If a file extension is (falsely) detected, the URL still gets a chance to pass via the URL scheme (“http://”, etc.). This change should be in GitHub Master in the next couple days.

is youtube going to be supported eventually?

For some reason Windows 10 put all my UE4 Game files on One Drive, When I try to import a Media Texture it won’t work. inside the player it shows the bar at the bottom progressing, but at the top is say’s the player is stopped. I’ve added all the videos to Contents/Movies and then move to import them one at a time, and nothing works. I’ve also tried creating a Media player in the same folder inside the Content Browser, and dragging the vid MP4 onto the media player, and following the steps in the forum. This worked once… only once. Half the time trying to direct the Media player to the vid clip I crash. I’m just trying to add it to my project, not even trying to package yet. What’s the deal?

I tried moving all the files back over to my normal my Documents folder and it still doesn’t work…