Media Framework Video not playing on mac

Most of my videos I have are in Mp4 what format should I be using because none of the videos I am using are working
Here is what is happening when I try to play a movie that I just imported and im not running on Ios im running on Mac and when I launch the game I use play in a new window in the editor

The media framework can’t find your movie file - in the movie file asset in the Editor change the path to be relative, i.e: ./Movies/JLC_CREATIVE_LOGO_ANIMATION.mp4

Upload the sample project you have - something odd is going on there and screenshots of the log aren’t enough to work out what.

I tried doing that but It says it still cant find my movie file :frowning:

I tried doing that but It says it still cant find my movie file :frowning:

How do I do that?

Zip up your project by going to the File > Package Project > Zip Up Project. Then upload it to a sharable google drive link (because the file size will probably exceed the amount allowed on answerhub). Share with us the link in your response.

There’s a bug when the filename has spaces in it that’s confusing the AvfMedia code - as a temporary fix replace the spaces in the filename with underscores and the movie plays just fine.

I just tried that and that didnt work it still gave me that same stupid error :frowning:

You have to change the name on disk

and the name in the UE4 asset in the Content browser

. Then it definitely does work as I have it running here using your project:

lol its still not working and its still giving me the same ■■■■ error…

So what do I do now since it obviously doesn’t work, I hope this issue is fixed by the time of the final public release :confused:

I’ve just fixed the code in UE4 4.13 to handle spaces in the filename so it will work in the next binary build.

So does that mean it will be working in the public version of 4.13 or in the next preview perhaps??

It should work in the next preview.