Media files are not played after the project is packaged

Media files are not played after the project is packaged. Everything plays in the engine editor, everything works fine.

You have to manually place the media files in the movies folder.

There is no movie folder in the packaging structure. I need to create it for myself, but where exactly to create it, in which folder?

You make a movies folder in the content folder, and put your stuff in there.

1 Like

I’ve already done this, but nothing helped.

You specify your movies here

After packaging, I seem to recall you have to manually make a folder called movies in the content folder and put the movies in it.

Apparently also possible to get them in the PAK file:


Here I made a video of how I do it, but nothing helped.

I just took the third person template. Made the movies folder and put an mp4 in there.



What engine version are you using?

I’m using UE5.

Well, that might be the problem.

I don’t have a copy of 5 at the moment to test, but it is a .00 release, so lots of things don’t quite work right.

Yes, you’re right. Maybe they will fix the errors. Moreover, I sent a form to technical support where I described this bug.


I had a similar issue in 5.0.3 and it turned out after switching the level, I forgot to add the blueprint which contained the media player to run the videos. Because in-editor I was still testing with the old level it took a moment to figure this out.

This worked for me. Unreal Engine: How to fix Media Player Videos not showing in UE5 with Ray Tracing or Lumen - YouTube

If anyone is still facing issue with playing media files, check out HISPlayer media player plugin. It supports both VOD and live streaming with HLS and DASH streams on Windows, Android, and VR / AR headsets such as Oculus Quest, Quest 2, HTC and more.

What you really need is to add the directory of movies files (.mp4, .wmv, etc.) to project settings->Packaging->Additional Non-Asset Directories to Package.

1 Like