MD-DL Error

Hello, today, i tried to install UE4.21 and each and every single time, i always get a darn MD-dl error and it doesn’t download at all. I have tried older versions too just to do this. My computer specs are below:
Windows 10 Home
Inspiron 3551
X64-based PC
Intel Celeron CpU N2840
BTW: i don’t think it is matter of whether my computer has enough memory or processing power as it doesn’t even download at all.

I’m gonna make a new user and try to install 4.19.2 on it which worked for my windows 7 laptop.

It did not work!

same problem here, did you solve it ( i saw your post is from 18’ )? i read in other posts that when you are in the option menu you have to wait until epic games end to process the “memory space”… but for me didin’t work at all. do you have anything to suggest to me ? thx

Same error. I tried to update 4.22.1 to 4.22.2 but it kept giving me this error. So I tried reinstalling the whole thing and I got the same error. Their “knowledge base” has nothing on this error(MD-DL) and I can’t find any other information about this issue.

Any pointers on how to solve this problem?

I am facing the same problem with the latest version of unreal engine.

I found that giving the Epic Games Launcher admin permission allows things to run/download. I’m not totally sure that it works for everyone.

Just run the program with administrator rights.