Maya rigging and animation tool Help

I follow the instruction and this is what I get when i try to build rig:
Could not save file: C:/Program Files/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/ART/Projects/Sample/ExportFiles/d_Export.mb not a valid file.
File may exist already and be marked as read only. Aborting operation.

It says D:/ in FillisterDock??!! Ive tried everything, followed the tutorials over and over again. What am I doing wrong. Could someone tell how they get it working???


Malmö,. Sweden

Hi dwnudwnu,

Would you mind posting this to so we can better assist you?

Thank you and have a great day!

ok i’'l do that

I recommend running maya as administrator, also be sure that the folder you are trying to save to is not read-only

Another advice: I would not recommend saving the engine or any other project to “Program Files” due to limited accessibility, try to use paths that do not contain any white spaces and are not influenced by windows

For example this would be a good start “C:/Projects/UE4”

Thanks Highflex, I’ll try that.


What version did you use?

Maya2014 says "read-only, but Maya2013 has worked well.

I created the Rig in Maya2013 and then animated in Maya2014.

I think “ART” is thought to function in Maya 2013.


Hey Aidan
I’ve tried with Maya 2013 and got the same result. But i’ll give it another try. It worked for you. What do you mean when you say “Maya2014 says Read Only”?


the problem is that the python script set the project into a full read only folder tree.

check out at the line 173.

projectPath = self.mayaToolsDir + "/General/ART/Projects/"

ok, thanks RedEyes, but is there something I can do about it to make it work??

I have the same problem with the with maya 2014 student version.

nope sorry i am enable to make the plugins to work
donot touch to the python code, i had copied the mayatools directory in a differnt place on my hard drive, and take care that every folder are nor in read only.
run maya and then go on the top menu > epic games > settings , and then replace by the new.

Now Try to Export, but it seem that maya is unable to save the file, and that break the process.

I got the same problem as the topic creator while trying to test out the rig on my own character. I would like to know how to fix this also.
Epic is aware of that issue, just wait for a fix.

line 14647:

cmds.file(save = True, type = "mayaBinary", force = True, prompt = True)

line 14829 :

cmds.file(save = True, type = "mayaBinary", force = True, prompt = True)

line 14955 :

cmds.file(save = True, type = "mayaBinary", force = True, prompt = True)

line 14987 :

cmds.file(save = True, type = "mayaBinary", force = True, prompt = True)

you must to set prompt=true, because of the warning message that saving process in maya occurs with student edition !

For the one who don’t want to edit the file themselves : you can download the file here and extract the file into your this directory : “Engine\Extras\Maya_AnimationRiggingTools\MayaTools\General\Scripts
Hot Fix :

Oh, Thanks RedEyes I’m really gonna ty this when I get home.