Download

Maya live link with Metahumans?

Hi all :slight_smile:

Has anyone been able to get Maya Live Link working with Metahumans?

I’ve gotten the body working sometimes, but sometimes not as well. Is there a straightforward “Maya Live Link for Metahumans” guide somewhere?

I definitely can’t get the face rig inside Maya to drive the Metahuman inside Unreal. Anyone know how to do that?

AC.

If anyone finds this post and wants to know the solution, I’ve written it up :slight_smile: This is how you can connect Maya and Unreal using LIVE LINK, using Metahumans.

You’ll need to adapt the names and namespaces for stuff, as I don’t have time right now to re-write this in a generic way.

UPDATE V2: I had to re-write this, because believe it or not (at least in 4.27), sometimes the original method works and sometimes it doesn’t. LOL. So I have re-written the instructions below so they work every time (there’s some redundancy, but it forces it all to work!).

====

For your metahuman, the body and the head are actually two completely separate pieces, so first let’s connect the body.

So to do that, in Maya, click on “MHRIG:Dhibody:Root”, then in the MayaLiveLinkUI dialogue box, click ADD SELECTION. Change the subject name to “MayaWizardBody”.

So then in Unreal, go to the World Outliner, and next to “BP_Wizard” click on “Edit BP_Wizard”. Now, in the components tab in the top left of the interface, click on BODY. Now on the right hand side, find the skeletal mesh. It’s a tile with a pink line at the bottom. Double click on that. Then click on BLUEPRINT in the top right hand corner.

Now in the bottom left area, double click on AnimGraph to open it. After the input pose, add a “live link pose” node. Specify the subject name as "MayaWizardBody ". Now click COMPILE, then SAVE.

OK now in the world outliner, delete the Player Start, so later on when we press play, your camera isn’t moved when you press Play.

Now, let’s connect the face.

So to do that, in Maya, click on “MHRIG:DHIhead:spine_04”, then in the MayaLiveLinkUI dialogue box, click ADD SELECTION. Change the subject name to “MayaWizardFace”.

So then in Unreal, go to the World Outliner, and click on “Edit BP_Wizard” just to the right of “BP_Wizard”. Now, there needs to be no components at all selected in the top left. Then, on the right side, in the Details panel, change LLink Face Subj to “MayaWizardFace”. Now click COMPILE and SAVE.

Now, in the components tab in the top left of the interface, click on FACE. Now on the right hand side, find the skeletal mesh. It’s a tile with a pink line at the bottom. Double click on that. Now, in the Preview Scene Settings tab, under Animation, change the Preview Controller to “LiveLink Preview Controller”. Then for the Subject Name, choose “MayaWizardFace”. At the bottom of the preview viewport, there is a green button labelled DISABLE. Click that. Click F to frame up. You may need to zoom out or around the viewport, but you will see a live preview of the facial movement from Maya, although the head will be rotated in an annoying position. Then press SAVE.

Now in Unreal, go to the World Outliner, click once on “BP_Wizard” to select it. Then in the Details panel underneath, at the top is list of things with blue icons. Click on the one labelled “Face (inherited)”. Now underneath this section, under ANIMATION, make sure the ANIMATION MODE to “Use Animation Blueprint”. Then make sure the Anim Class is set to “Face_AnimBP”. Now click to turn on the checkbox next to “DISABLE Post Process”. This is vital, otherwise it won’t work.

You must now press PLAY in Unreal to make the connection work.

1 Like