Maya exported staircase unable to climb/jump up or pass under

Thanks to help from this forum I can finally export from Maya2016 to Unreal 4.8.3

In Maya I built a staircase, nothing fancy.

I placed it in Unreal and thought “finally getting somewhere”

Not often that I am right but this time, I was wrong again.

The stairs don’t let the player climb or jump up them and also stop the first-person player and any projectiles from passing through the empty space under the stairs.

Can someone point me to which end of the process I cocked up this time and tell me what I did wrong?


When importing a model u probably have autogenerate collision on… and your collision is probably just a box with that… that covers everything. For a model like this u would normally want to create your own collision and export that long with the model in the same file. You can look up that process yourself in the documentation or google.

As Kurylo3d said, the problem is the auto generated collision just being a box around the entire stairs. As mentioned you can create you own collisions for the object. It can be single or multiple objects. It’s a pretty straight forward deal.

The other option, which is the slightly more lazy but simple option:

If you open the mesh in Unreal Editor. Under the collision options for that mesh, there is a selection that is default to simple box collision. You can change this to complex and it will copy the shape of the object. I’m sure it’s not too big of a problem for a low poly mesh like your stairs :slight_smile:

Static Mesh Settings -> Collision Complexity -> Use Complex Collision As Simple

That’s what I’ve used with good results on door ways etc.

Some more ways how you can create a collision: :slight_smile:

Thank you all for your reply, I only have 6h 7min (but who is counting) before work is over then I will fix up my mistake.
Thank you again.

Tried the lazy way first as you all expected and it worked.