Maya Animation Rigging Toolset Crash

EDIT: Just a quick update… I am still seeing the error messages in Maya, but I went ahead and used the tool today to create a full character rig without a problem and without a crash.

Hi, I installed the Maya Animation Toolset and used it to follow the tutorial videos. However at the end I hit ctrl. z to undo something I had done. This caused Maya to crash. Now when I open Maya I get this error message:

Error: file: C:/Autodesk/Maya2014/scripts/others/performGpuCacheExport.mel line 566: IOError: file C:/Game Design/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Scripts\ line 249: 2

Also trying to load the Epic > Character Rig Creator within Maya, results in another ctd.

I haven’t reinstalled the toolset to see if it can be fixed that way because the files came with the entire UE4 installation, so I think I’d need to re-download everything to get fresh files. Before attempting that I thought I’d ask here first.

Does anyone know what to do? Thank you!

Hey. While I know this was asked 4 days ago and you might have already seen it I figured it would be best to say it anyway. The guys at Epic have already confirmed that this is a known issue and they are working on it. Do you use a Maya Student edition as well? Since so far I have yet to see anyone with the ordinary Maya have any issues. Which is strange since they are identical. Only difference being the dialogue box showing up when you open a project made with the student edition.

I have the exact same problems that you do. So I hope they fix this soon!

Hey, thanks for the reply. Glad Epic are on the case, hopefully we’ll get a fix soon. I’m still experiencing the issue. I haven’t tried to do much with it, it’s just sitting there bugging out.
I’ve got the regular version of Maya.

Hey, I fixed this on my end.

#setup script jobs

#scriptJobNum = cmds.scriptJob(event = ["NewSceneOpened", launchCustomFileLister ] )

#scriptJobNum2 = cmds.scriptJob(event = ["NewSceneOpened", mayaTools])

Comment out the script jobs in the I try to avoid the use of script jobs whenever possible.

EDIT: I’d edited this post previously to indicate that I’d changed the order that these tools ran, which fixed my hard crash, but I guess I forgot to save the edit. Sorry about that. (Maya 2014x64)

Removing the script jobs won’t help with the student version. The Student version issue is caused by the save functions suppressing prompts (which doesn’t play nice with the student version reminder popups). This has been fixed, and we are waiting for the next opportunity to push those changes out.

Hi Adric, I have another issue, perhaps one with a simple answer. I’ve created a rig with the toolset, however I am unable to skin my own mesh to it.
The error I get is: “// Error: line 0: Problems occurred with dependency graph setup” Any idea why that would be? Thank you!

A user in this thread had the same error.


Interesting. Your explanation makes perfect sense. However, I was getting hard crashes on launch.
I changed the order and ran mayaTools() first, and then launchCustomFileLister() second, and it ran just fine.

I am having the same issue when proceeding under A.R.T. Selected Object in scene and clicking: Skeleton Placement. Once clicked Maya 2014 (full x64 edition) closes out. Previous hotfixes have not worked, however it seems to be specifically failing at Fatal Error. Attempting to save in /AppData/Local/Temp/

This is now resolved!
Check the official thread created detailing known issues, frequently asked questions, and upcoming features as well as the latest code drops:

ART Master Thread