Download

Maya animation not bound to poly in UE4

Hello,

I’m kind of a beginner in animation and UE4 and this is my first post on the forum.
I have been struggling for some days on a basic animation that I export in FBX from Maya to UE4. The animation consists of two doors moving left and right from a central frame.
Here is how it looks in the end in Maya:

DoorsOpen.PNG

Sadly, once imported in UE4 what happens is that the joins move but not the doors. Here is how it looks in the end in UE4:

DoorsOpenUE4.PNG

As you can see the doors are still closed even though the joins did move. For information I used the “Smooth Bind” command in Maya to bind the joins to the left and right doors.

Obviously I’m looking for some help here. As a beginner I guess I did a lot of things wrong but I don’t know what, when, and where. I spent some time with tutorials and videos, I also took a good look at the documentation related to FBX pipline but I saw very little info that could relate to a simple case like mine.

Thanks in advance for any help you could provide, let me know if you need more info.
John

I don’t see why this should have any issues. The only thing I see that kinda irks me, is that you have the Root inside a transform group. I would recommend always leaving it at the root of the scene to avoid problems.

Apart from that however, this should work. Care to share the scene?

Having the exact same issue. Would love to know the answer to this! In same boat experience-wise as well.

Would it matter if my rigged mesh in maya that’s animated is not centered on the grid? I’ve tried baking the bones, baking the mesh, baking in the FBX settings, turning off animation, leaving it on, as well a a variety of other settings and I can’t seem to figure this one out.

Thanks for any help on this guys!

I reproduced the effect with a simple scene I’ve attached. If anyone could take a look to see what I’m doing wrong that would be really awesome :).

I tried 2 methods of export from Maya, they both are explained below -

Method 1 (mesh nor bones animate): - Under Character > BoxCharacter Attempt_01 in the file - I tried exporting 2 files in total, one with skeletal mesh and bones, imported as skeletal mesh, and then imported the animation (selected all the bones in maya, exported with them baked in the FBX settings). Result is nothing moves at all in Unreal. In fact the joints aren’t even in the right location.

c9cbe2bf86ab11511dfcd1ad51eef72784b87905.jpeg

method_01_AnimationExport.JPG

**Method 2(bones animate, mesh doesn’t): ** - Under Character > BoxCharacter Attempt_02 in the file - I select the mesh in Maya, as well as all the bones in the hierarchy, and did edit > keys > bake simulation inside of Maya to bake every frame, and then export with animation on and bake on in the FBX export settings, and the result in Unreal is that the bones will animation correctly, but the mesh does not.

590bd63fabaed92433b8a15dbbd53318c767613d.jpeg

file (to download easier open in Google Drive > right click > download): https://drive.google.com/folderview?id=0B06WV4J3IPjIfmpVbVRQcUVEVXhtYWlSZHFVRXBmQVFnX3Vrck0wQmlleUlKZExMYVZPRjQ&usp=sharing

I’m sure I’m missing something simple, but I’ve followed the documentation here, as well as a couple video tutorials like this one (which is my method 1 I used), and derpy derp, doesn’t work.

To anyone who can help me out with this I would be eternally grateful.

What do you get if you import the FBX back into Maya in an empty scene? (don’t do it in the same scene as FBX tries to be “smart” and merge stuff)

Got it working just now! So in exporting, I first baked all the bones down inside maya, second run a scene optimize, with everything checked, delete anything that influences the geometry or bones that isn’t the geometry or bones, such as curves, random group objects etc, when exporting I used my “method 2” where I select all the joints in the hierarchy and the mesh and in the export options turn on animation, but turn off bake. When importing that into UE4 I import as skeletal mesh, but turn off animation. I then go back to my Maya scene, export all the selected bones again, export with animation, turn off bake, and import that into Unreal as the animation and vuala, it somehow works.

I’m going to trouble shoot this further once I have more time to figure out the root of the problem. I’ll post a follow up for to pinpoint the exact issue for any other newbies like myself who stumble across this thread, for now I just need something that works. :slight_smile:

I would say the group objects have a part to play in the problem. I got mine working fine by deleting the history of the objects before putting them into a hierarchy. Still looking further into it though.

Hello,

When I import back the FBX in Maya (in a new scene) I get the poly and the anim fine.

I also tried a lot of things like baking in Maya/during export, running a scene optimize, deleting history, importing first the Skeletal mesh then the anim but it never really worked.

I will move that root item and try exactly like you did Mountain and let you know if it works for me.

Thanks all,
John

Hi,

I tried as you described but it doesn’t work. Also I was wrong: importing the FBX back in a new Maya produces the same issue that I have in UE4.
f you want here is the scene file: MEGA

Maybe there’s a checkbox I missed when exporting or it is something more complexe…

John

Works perfectly on my end. Unparent Root to the scene. Select Root + Group. Export as mesh. Select Root and export with animation. This using FBX 2014.

If I understand well you took the root + joins out of the group? That bothers me because doing this and then importing Root + Group as mesh in UE4 results in an error that reads something like “There is no root bone on the mesh”. Could you tell me what options are checked when exporting as FBX? I will also check my FBX version. I use Maya 2013 and I don’t know whether it is possible to use FBX 2014 on it.

I would say keep it simple. Probably you don’t need grouping to make this work. I think that is complicating things a bit. And it is also a reason for some of the errors you are getting. For a simple prop animation like this I think it would be much more predictable if you only had the mesh and the joints. Animate the joints, select the mesh and the joints and use Export Selection and bake the animation.

I think if you are building a rig it is also best to build it in two parts. One it the control rig that uses various constraints and so on and another is a clean hierarchy of joints with the root in the scene not in a group that can be baked down on export. Normally this is called a deform rig and the one with more complexity is called the control rig. The deform rig should just be a simple bone hierarchy, no constraints like parent constraints and so on. Keep all of that on the control rig. And in this scenario export only the deform joints by selecting them and the mesh. Even if the deform rig is contained to the control rig with constraints, there are no constraints that actually hold it together or groups that break up the hierarchy or keep it out of the root of the scene.

But for simple prop animation it really only needs to be mesh and joints. For more complex mechanical (or character) rigging introduce a separate control rig.

If you build your set up with export in mind, you won’t need to do these extra steps. Try separating your controls from your deform rig which is the joints in this case. Take the joints and the mesh out of the group and make it so that they have a root in the scene. Constrain them if you like to the control rig as needed. But when you export, select only the mesh and the joints and then export that. Baking (Edit/Keys Bake simulation) on the joints is required in this case.If you don’t have a control rig you can bake it on export instead.

See if the 2013.3 plugin version works better for you. I see it more likely to be an outdated FBX issue rather than something in your scene.