Maya Animation and Rigging Toolset| cannot bind skin

Hi,

Thanks for making the toolset. It looks great but im unable to bind my own mesh to the skeleton.

At the deformation setup phase I am trying to smooth bind my mesh to the skeleton. All attempts have failed so in this case, I am using a sphere for a simple test. I’ve used all the default A.R.T. settings on my way to the deformation setup part and I am selecting my sphere (pSphere1) and ctrl+lmb “root” skeleton node. when i click smooth bind i get the error:

SmoothBindSkin;
performSkinCluster false;
// Error: line 0: Problems occurred with dependency graph setup. //

If i then try to go back to Skeleton Placement, I get the error:

Error: TypeError: file C:/Program Files/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Scripts\ART_skeletonBuilder_UI.py line 21299: ‘NoneType’ object is not iterable

At some point I also came across this error so I’m leaving it here in case it’s helpful:

// Warning: Panel size cannot accommodate all requested Heads Up Display elements. //

Warning: ‘spine1_shapes.spine_1_bust’ is already connected to ‘spine2_shapes.spine_2_bust’.

UI Refreshed

Error: RuntimeError: file C:/Program Files/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Scripts\ART_skeletonBuilder_UI.py line 17425: Problems occurred with dependency graph setup.

Thank you for any help.

I’m also getting the same error…Any ideas?

I have the same problem:

I have a my own model mesh and the rig that was created with the UE4 A.R.T. toolset in Maya that I need to bind together, however when I try and smooth bind these in Maya 2014 I get the following error:

Error: line 0: Problems occurred with dependency graph setup.

Anyone know what I can do to fix this ?

Ah,okay.This issue just isn’t properly documented.So,you first need to ‘publish rig’ (just make it look as close to your custom model as you can;I also kept my own mesh inside this file,just in case),and after that,once it’s ‘published’ (make sure you specify a new name for the project and for the character),I clicked edit rig button,and then you can smooth bind your mesh to the newly published rig…

Hm, that is indeed a bug then. What seems to be happening, is I lock down the skeleton after the deformation setup phase, but it doesn’t get unlocked until the publish phase, which is incorrect. I will fix this as soon as possible and get the files on github updated. I’ll also post dropbox links in this thread for immediate download as well. Thanks for finding that workaround Michiyuki13!

Just got stuck on the same part… “Error: line 0: Problems occurred with dependency graph setup.”

see if Michiyuki13’s workaround will work for you. I’ll be updating the code within the next 24 hours.

As for any other errors, just paste the error messages you get and the maya version you are using and I’ll do my best to get them fixed as soon as possible!

Hi Jeremy,
Where on GitHub can I find ART, I can’t seem to find it at EpicGames?

It’s in the source under Engine\Extras\Maya_AnimationRiggingTools

hi Jeremy,

woohoo! thanks for looking into this. I’ll check Michiyuki13’s workaround when I get home. I think I remember doing something similar and having it work.

kfredberg: if you’re asking about the original a.r.t. script, you can find it under program files/unreal/engine/extras/Maya_animationriggingtools. I can’t check the exact path at the moment but its in there

this is a long shot but I might as well ask while I’m In here, any chance anyone knows a tutorial/resource for exporting set driven keys? it’d be great to have them working on my rig in ue4.

thanks!

thanks, but I was looking for the repository on GitHub that Jeremy refered to.

Oh sorry, I see what you mean…

Yep seems the only way to get it is through the releases page on GitHub rather than being visible in the navigable sections of the GitHub repository

Link in case you don’t have it (not trying to be patronising):

https://github.com/EpicGames/UnrealEngine/releases

The source code zip contains these extras.

EDIT: I have now logged a feedback request to get these files on the main repo.

I have the same problem I,m working with maya 2013

Hi all

I have found a work around that you can do before completing the rig:

On the step where you would attach your model run the following command in MEL script:

string $gffu[] = `ls -sl`;
for ($rfo in $gffu) 
{
 lockNode -lock off $rfo;
}

This will unlock the nodes for binding to the mesh. This will allow you to use your own mesh and do the weight painting as described in the rest of the tutorial !

If you run into any problems let me know.

(P.S. I do not work for Unreal - this is not an official fix)

yeeeei that works amazing thanks!!!

This worked for me, Thanks!!

Thanks SwitchNZ!

So that worked an all and let me bind the mesh, but now when trying to re-“build” or publish the rig I get this error:
# Error: RuntimeError: file C:/Program Files/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Scripts\ART_skeletonBuilder_UI.py line 14563: setAttr: The attribute ‘root.rotateX’ is locked or connected and cannot be modified. #

Anybody have an idea on what could cause/fix that?
This error is happening in Student version of 2013, and its in both cases of trying to build as a new Character and trying to build as the pre-existing character.

Thanks SwitchNZ ! everthing works!

The dropbox files have now been updated to fix this issue!

link