Download

Maya 2018 FBX export not working with UE4

Hi people,

I have tried exporting my mesh and rig from Maya 2018.3 (it doesn’t matter which version of FBX I use), but it isn’t recognising the skeleton at all. Maya 2017 works fine, with all the same settings. I’ve ran out of things to try. UE4 just says that it is a static mesh and if I just export the animation UE4 cannot recognise the format because it cannot find any mesh (which is fine because it doesn’t have one) or any skeleton joints… which is not-so-fine. :frowning:

The only difference I can see between the two versions is the actual FBX version (revision) number, in the Info box.

The character is animated with a control rig, so the actual skinned joints aren’t directly animated, but this has never been a problem before. Like I said, it exports fine from Maya 2017 with all flavours of the FBX exporter. Look at the two file sizes. Maya 2017 is about 200 KB larger because it has also exported the animation.

Has anyone had any similar problems… and, more importantly, did you manage to resolve them? Is there a setting I need to turn on, now, in Maya 2018.3

I can share my rig and mesh, if anyone wants to take a look at it?

Thanks,

Neil

These are the settings for both Maya 2017 Update 4 (that exports correctly) & Maya 2018 Update 5.

I tried exporting from my home version of Maya 2018 (no updates), it exported fine, like Maya 2017.4