Max Draw Distance behavior changed in 4.15

I’ve opened my map in 4.15 and everything started to cull too early. I have a map made from large merged meshes and finely adjusted Desired Max Draw Distance per mesh. In 4.15 Max Draw Distance seems to work differently. It feels like it takes distance not to mesh center but to furthest boundary of mesh, something like that. As a result, meshes began to disappear at noticeably shorter distance than before. Apparently, I can re-adjust Max Draw Distance per mesh with bigger values, but… why did this happen, anyway?

Steps to reproduce:

  1. Start UE 4.14.3.

  2. Place a large static mesh on the map, set some Desired Max Draw Distance for it. I use meshes of size ~3000-6000 units and similar draw distances.

  3. Run the map and notice the distance at which mesh appears when you are getting closer to it.

  4. Open the same project in 4.15.3

  5. Run the map and notice that distance at which mesh appears is shorter now. You need to get closer to mesh to see it on screen.

Attached are the same spots of my map seen in 4.14.3 and 4.15.3 Preview.

Hey diamond3,

I am not seeing the same results on my end when running a simple test with a single cube and setting the max draw distance to 4000 UU(unreal units).

4.14.3 Visible

4.14.3 Culled

4.15 Preview 3 Visible

4.15 Preview 3 Culled

As you can see the distances are correct and culling out the geometry as expected. Perhaps I am overlooking something, or that you have set the min draw distance as well.

Let me know if you have further questions.


Can it be that culling works differently for merged meshes?
I’ll try to build a test project during weekend, also.


EDIT: Important observation! This happens in Play-In-Editor mode only. Standalone launch work well.

I’ve made a small project which reproduces the issue. Essentially, this is an extract of 3 meshes from my project. A couple of things in your pictures look different from my case:

  1. size of green cube seems too small, I use meshes of size 3000…6000 units.

  2. my meshes are placed far from world’s origin, maybe this affects the issue too.

Download link:
Steps to reproduce:

  1. Download and open project in 4.14.3
  2. Open the same project in 4.15 preview 3 (it will ask for conversion)

Image in 4.13.3:

Image in 4.15 Preview 3:

Thanks for the repro project and provided the extra information as requested. I was able to reproduce your issue in the project provided and have gone ahead and entered a bug for the issue. You can track the issue on our public issues tracker by following the link I have provided below.


Once the issue has been fixed, it will be updated with a Fix Version and the status will change from Unresolved. Let me know if you have further questions or need additional assistance.

Thank you,

i just figure it out you have to on the Level blueprint on event begin play with console command r.ViewDistanceScale 10.the difault its 1 i think its medium or epic