Matinee won't track camera for movie export

I’ve looked at questions similar to mine but I can’t seem to find the solution still.
I can’t seem to make my camera matinee sequence start on the level load up when rendering the movie file.
I have a director group, a camera group, keys, and the “load on level startup” option turned on. I don’t know why but even with all of that it doesn’t show the camera matinee I made for the movie. However, the matinee startup works perfectly fine when you press play, for game play.

Before this issue I was having a different issue where the camera wouldn’t update the keys and wouldn’t show the latest render of my scene and kept playing old ones. And I made different cameras and keys but still nothing worked.

So I ended up going to my Render Movie Settings “THINKING” under the tab General>Level> and then choosing one of the level load options would fix it… But after changing the level load location all camera moves stopped completely and don’t render out. So I think it’s the cause of the problem I have now. I only have one level called Minimal_Default, and then there’s an option for StarterMap - Level. Neither of those work when I change to them and I don’t know how to get the default setting back to what it was. When I hit reset to default it just says “none”. I’m pretty sure it was called matinee under the level options before I made the change… Or something. I don’t know I just don’t seem to have the same options as I see on other peoples UE4 projects and I tried doing a search for it and nothing comes up. I even tried restoring preferences to default and nothing.This is what it looks like. I circled in red the area I’m talking about that I ended up changing.

Somehow it resolved itself despite the numerous other times I had restarted it. Must have been a bug.