Matinee sequence movement not playing after initial run

I have a matinee sequence with an elevator platform that moves between floors. On the initial run all movement runs fine between the floors with a 3 second time frame of movement, after I run through all matinee sequences and try to go between the floors again, the matinee sequences just jump between the floors instantly but the actual 3 second movement of the platform no longer happens.

I have the 5 sequences linked to a MultiGate in Blueprint firing off each time the X button is pressed. I have tried setting the MultiGate to “Loop” and also setting it to “Reset” which does not make the outcome any different. Is there something that I am missing to have the matinee movements play the movement the second time going through the sequence or is there an issue?

Ok, I guess maybe posting sometimes helps answer your own question. Having the last matinee sequence set to reset the MultiGate sequence and then setting each matinee sequence to rewind on play seemed to have solved the issue with the matinee sequences not playing the animation on multiple run-throughs of the player action.

Hello,

I have a scene with a water wheel that I would like to continually rotate. I created a matinee track for it and set a simple linear 360º rotate on it. I can only get it to play once. You mentioned “rewind on play”. Is that done at the matinee level, or the blue print level? I have been looking all over in matinee, but can’t seem to find any option to have a track repeat/loop, or rewind. I’m missing something.

Thanks!

Select your matinee actor in the scene and check the Details panel, there you’ll find Loop tickbox.

sorry for the late response I have not been online for a couple days. I found out you don’t even need to create a blueprint from your mesh to work with the matinee sequence. Set your mesh to moveable. When you are making your matinee sequence, make sure your mesh in the level is selected when you make your empty group, and then your movement track and you should be fine to make your sequence. Like Jacky mentioned, select your matinee actor in the level and then in the details pane there is the option to set the sequence to looping and that should work for the animation repeating.

The rewind on play was something I needed for the hotel elevator I was working on with the elevator not starting back on the beginning sequence after it had moved to a new floor. So I have 5 floors the elevator goes to and when I was back down to the first floor and tried to go up the floors again the animation wouldn’t play the elevator just jumped to the next floor so using the rewind on play check box allowed for the animation of the elevator moving to start at the beginning.

Any other questions feel free to ask.

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

Hi- having this basic same set of problems in w/ 4.9 1 yr later from this post, on mac with matinee actor enabled for looping , rewind on play etc, blueprint setup etc? the animation worked well for 360 degree rotation on loop first time though but with saving and re-opening in matinee the animation no longer plays in matinee editor or in a level build.

Hey paradise10010,

Would you mind showing me a screenshot of your Matinee set up and how you are calling your matinee to playback?

This will help me visualize the issue a bit better and get a starting point of reference. Simple steps to reproduce this issue would also be beneficial for determining the validity of the bug.

If you have further question, please let me know.

Thank you,

Andrew Hurley

Hi okay thanks for taking a look. I’ve had unreal engine for a couple years but im finally building something, so this animation isn’t critical rather just wanted to add it for a test now early on, to check that everything is working. It played the first time BEFORE i add the blueprint? did I mess up or is it a bug? There are 3 keyframes and the ‘tesseract’ object (in black) rotates a full 360 on one of its axis’s thats about it. The blueprint is just the basic play setup, i’ve also tried play on level load, rewind, and checked to make sure its moveable. >> I’m also having other trouble with windows sliding around, scroll zoom -/+ inside the matinee, keyframe areas not resizing and , anyway it feels like this part of the program is a bit left behind ? When I tried starting over key framing, it was having trouble selecting the object, then saying i had no track selected… even though i had just setup the same animation. In the first screen shot you can see the animation should be playing on loop but doesn’t anymore, with 3 keyframes here. Did I miss something simple or just working too late at night? Thanks a ton!

Hey paradise10010,

So you seem to be on the right track, but might need a refresher on how Matinee cinematics are set up. You will want to have a director track and some blueprint logic to control your matinee’s playback.

The main thing I am seeing is you have not added a Camera Group, which you will need to view the tesseract rotating when you play the cinematic.

Matinee Refresher

Let me know if you are still experiencing issues and I can help you troubleshoot further.

Thank you,

Andrew Hurley

Hey thanks … your awesome. there are so many dimensions to using unreal its hard to get mastery on all of it simultaneously… For anyone following this, I actually fixed my initial animation problem by disabling casting shadows? it gave me a lighting error saying *cube shape etc etc would severely effect performance if enabled etc. and it started working after that.