Matinee - Out of memory


I don’t know if it’s really a bug or if I’ve made something wrong.

When I “Record Movie” in matinee (.jpg / 30fps / stream texture or not), the computer start to go out of memory and finish by a BSOD.

The memory used by the UEeditor process increase very fast ( about 100-200Mb/s), after 1 minute my memory (16Gb) is full and start to swap. Pagefile.sys is managed by system and I think the system limit it to about 25Gb. And Windows alert me that I run out of memory.
I can avoid BSOD by shuting down the editor fastly after the Windows alert.
I want to record a sequence of 3-4 minutes, but crash occurs at 2 minutes and few seconds.

My Spec: Core I7 3770k / 16 Gb of RAM / Plenty space on differents SSD/ GTX 960 4Gb
Any ideas?

thanks by advance

I’ve been able to export the video frames with command line (only 2 or 3Gb of RAM used instead of more than 40Gb…)

"C:\EditorPath\ue4editor.exe" "ProjectPath\ProjectName.uproject" -game Content/Maps/LevelName.umap?-ResX=1920 -ResY=1080 -BENCHMARK -FPS=30 -MAXQUALITYMODE -DUMPMOVIE -NOTEXTURESTREAMING -FULLSCREEN

All is exported in Png, very long and voluminous, but it works.

So if you have any ideas of to make “Record Movie” works in matinee, I will be happy to read you.

Hey Metathesus,

Can you send me a screenshot of your Render Settings window? I’d like to see all of the settings you’re using. A setting that might help you out is “Use Separate Process”.

I can’t seem to reproduce the memory increase. Are you able to reproduce this on a basic template project?


Hey ,

I’ve tried with a the template project “First Person”, the problem does NOT occurs.

Screenshots here:

If you needs some obscures logs, I can send them to you after you specify me what exactly you need to debug.

Thanks for your time!

Can you check your output log for any log spam? Look for some Access None errors, that kind of thing. Can you try a “Play in New Editor Window”(No rendering) and let me know if that also causes a memory increase?



After your request, I test and It seems the bug go away.

I’ve made a lot of changes on my project (most on BP) , so I don’t know what changes made the trick.

If you really need to track the bug, I can restore an old save for UE4 Development and check if the bug was present.

Thanks for your help

Hey Metathesus,

That’s great! It may involve a lot more testing to track down, but might be easier now that you have broken/working versions of the project. The first thing we’d do is get a copy of the output log. We’d also run a memreport and see if we can track the problem there.

So it’s up to you if you’d like to continue investigating.


After Investigations on a backup, I’m pretty sure that my bug come from this function (in my custom skysphere) on “Event Tick” instead of “Event Begin Play”

Now Movie is OK and I haven’t a performance drop after one minute of gameplay.

My Output Log was showing nothing interesting about that.