Matinee Movie Stuck At First Frame

So I’ve done every single tutorial, looked through every single forum, and scoured the entire bloody internet and can NOT figure this out. It is currently taking all of my strength not to throw my $3000 computer out the f***ing window.

I’m doing a test camera animation in UE4, so I can work out a pipeline to use for rendering a series of animations later. I’ve got a very basic skeletal mesh driving my camera, and when scrubbing through Matinee, everything works exactly as expected. The viewport is problem free, the animation is there. My director and camera groups are perfectly set-up, I’ve got the blueprint command that plays the Matinee compiled, and I’ve set the Matinee to play on level load.

But then I render… No matter what settings I have, it just refuses to work. I start capturing and the pop-up snaps to my camera at the very first frame, but then NO animation follows. It is JUST the first frame of the camera movement. I can SEE the foliage waving as it captures, so I know it is not truly stuck at frame one, and when I end the capture, I can go to my output folder and watch the video. Everything is moving except the camera! I have followed multiple other tutorials TO THE LETTER, but I STILL do not get the same results as them!

I am extremely infuriated, so I will probably be very vocal until this is resolved. If this question is ignored, I will post another. I’ve come very far, I need this to work.

Any help is appreciated.

Could you please post a screenshot of your Matinee? Also can you try creating a new project(without starter content) > setup a very simple matinee camera animation and see if it still the same as before? If it is, please upload the project to dropbox or googledrive so that we can take a look.

So I did the exact same things I did in my project in a fresh scene, minus the skeletal mesh, and it appeared to render just fine. However, I checked my skeletal mesh in my original scene, and everything appears to be animated normally in the viewport, so I don’t think a skeletal mesh should make that much of a difference. It is much easier to animate cameras in Maya than UE4, so I would very much like to resolve whatever this issue is.

Also, I tried rendering my original scene for the hundredth time this morning and it just straight up crashed. Not sure of that’s relevant or just an anomaly.

Thanks

FOR ANYONE SUFFERING FROM NO ANIMATIONS PLAYING WHEN RENDERING/MAKING A MOVIE:

I am answering my own question here. After many days of scouring, and bleeding from the ears, I was playing around with every option in UE4 and found that a small, inexplicably technical box under the skeletal mesh options called “Mesh Component Update Flag” should be set to “Always Tick Pose and Refresh Bones”. This solved my problem of no camera animation when using a skeletal mesh.
Why it is set to just “Tick Pose” by default, I have no idea, but everything appears to be working now. This is not really an intuitive option that most people would think to look at for something so simple.

I will list some other tips to try, should anyone find this post by wondering why Matinee is not playing nice. All answers I’ve collected by googling my problems in the past.

  • Select your Matinee in the Outliner and make sure the box labeled “Play on Level Load” is CHECKED. This prevents the renderer from automatically creating a camera at world origin (or using the player cam).

  • Hook up an “Event BeginPlay” to a “Play” node in the Blueprint level editor and hit “compile” on the top left. The “Play” box should automatically bring in your Matinee box. You can right-click and search for both nodes to easily add them.

  • Under the “Render Movie Settings” dialogue window when exporting your movie, keep your output directory short. It’s best to set it to your desktop, and create a subfolder there. Example: “C:/User/YOU/Desktop/Render”.

  • Under the Matinee actor in the Outliner, check the boxes “Rewind on Play” and “Rewind if Already Playing”. That may solve syncing problems.

  • Make sure no actors are hidden in game. There should be an option for this under your Matinee actor and your skeletal mesh actor.

  • Make sure your director group’s keyframe uses your CAMERA, and NOT your skeletal mesh.

  • Double-check your skeletal mesh is actually using the animation you imported, in the Outliner Details pane. It may be accidentally set to “Animation Blueprint”, or the “Anim to Play” box may be empty. Also, set it to “Playing” and “Looping”, just in case.

  • Make sure the teeny tiny check boxes to the left of your director group and skeletal mesh in Matinee are CHECKED.

  • PRO TIP: You can select the little camera icon next to your camera to change your viewport to that camera, in Matinee.

Hopefully these tips help somebody else. I only needed a few of them, but they are all solutions I’ve seen to other people’s problems in my searching.

Good luck, and happy developing!

Ohhhhh! I have the same problem,without ur sharing I m afraid I can’t solve it. Thanks a lot!