Download

Matinee Import from 3D Studio Max (world position not correct on objects?)

Hello all,

I was wondering if anyone has any experience with the whole export/import from UE4 to 3D Studio Max and back.

It appears that exporting the data/entire scene from matinee and importing it into 3D Studio Max works just fine, but it looks like when I export my scene from 3d studio max using fbx 2012 with baked animation/resample all and reimport it into matinee all of the objects get pushed around/meshed up in both position and rotation, although it looks like my simple test of translating an object up and down was successfully imported.

I did change the settings to z-up which seemed to fix everything being rotated to the side, although the positions are still drastically messed up.

Does anyone have any suggestions? I’m wondering if it has something to do with either world position or perhaps the unit scale on exporting. I’d love to get this to work as I have a lot of objects that need object translate/rotate-type animations in a scene and it’s so much faster for me to keyframe it in 3D Studio Max. (buildings rising, cars/trains following paths, objects building “built” etc. basically everything that could be solved in the movement track)

I recorded a short video of a simple test as I’m trying to make it work, showing the general problem.
[EDIT] Link fixed
http://youtu.be/GpV31euUkzo
Thanks

I can’t seem to watch the video, but from the sounds of it, it’s possibly a scale issue. That’s most common, and about the only thing I can think right now, causing such problems.

I’m going from memory here, so bare with me. When you import to Max, by default the scale would be set to automatic, in which case Max could get the scale wrong from a UE4 exported scene. This has to do with your scene setup… etc. So on your import setting, check the scale, it will show you the ratio, if it’s set to automatic, the ratio will still show, it’ll just be grayed out. So if that scale ration is not “1.0”, then tick off automatic and choose a unit type manually, so you get a “1.0” scale on import.

I don’t know why Max can’t automatically get a 1.0 ratio, but, it can’t, I think that automatic unit it selects is simply based on your scene unit settings.

On export, I usually have it set on automatic. I’m not sure of possible cases where you have to change that. I generally keep units set as default by Max, meaning Generic Units, International. In which case the scale translates properly. But if for whatever reason your export comes out wrong, you can check the scale settings again and make sure it is correct for export.

Thanks for the reply, I fixed the link!

I’ll try fiddling with it some more but I think I might of already tried your suggestion. I’m not entirely sure that’s it either as the rotation of the animation would still be messed up (facing the wrong direction even after setting z-axis to up on export from 3ds max to unreal)

Hopefully it’s just some simple thing I’m missing rather than a bug.

I am interested in this at well. So. Bump!

Watching the video this time, I have a theory for you. I’m not basing this on any experience other than some UDK matinee experience, though I’ve never exported animation for matinee, so I’m making some assumptions. But it’s something to look into I think.

It could be that it’s using local space, so before you export, you need to reset the rotation and position to 0,0,0. So, you don’t reset XForm, but you type in position and rotation to be 0,0,0. So my theory about what happens is you exported the model at an offset from world 0, then you exported the animation at the same offset from world 0, so you get a double offset, the current position + the animation. And same would go for the rotation.

The other possible way to deal with it is, I remember in UDK it was possible to switch matinee to use world space in stead. If I remember correctly it used local by default, but it’s been a while since I worked with matinee, so I’m guessing here a bit. So with world space, the animation “should be” basically absolute. You could look at that and see what’s happening, is it in fact trying to set the animation in local space or world space and if you made it world space, does it in fact work or not, or try exporting the animation from a zeroed position and rotation.

Was anyone ever able to figure this out?