Matinee doesnt record hud or any UMG?

I have tried with cinematic mode on and off. As well as playing with the hide hud check marks. on and off. No matter what I do I can’t seem to get my hud to be recorded in Matinee when making a video. It shows up there and is interactive during the recording, but doesnt show the interaction in the actual video.

Is this a bug? or is there something else I’m missing somewhere?

anyone ?

=(

not avail in UE4 at the moment

ahh cool good to know.
i cant upgrade since 4.9 breaks most of my stuff and the game is too far along to sit and rework everything.

Shadowplay works pretty awesome though as suggested by one of the devs in the forums. Been using that lately,.

It works in 4.9.1.

Just uncheck “hide hud” in movie settings.

Any ETA on a fix for this? We really need to be able to record our HUD via Matinee.

if you have a vid card that can do it, I’d recommend shadowplay. Its MUCH MUCH better. The quality is HD and the vid size is reasonable. No choppiness when recording. The UE4 recorder makes unbelievably large file sizes and it’s usually really slow while recording.

Yeah, I am using OBS, and it seems to work fine.

Still, though, UE4 should have support for this.

Hello Mothership.Entertainment,

I found a feature request that was entered to add support for this option (UE-7368). I have increased community interest on the issue and linked this thread to the feature request report. Currently it is not on the roadmap to be integrated at this time. As thankstipscom mentioned, I would use shadowplay or another external application to capture and export the matinee.

Thanks,

Andrew Hurley

Thank you for the input.

Yes, I’m using OBS, but I hate to have to use this as I am noticing video quality differences between matinee-recorded videos and ones made with external tools.

Also, if HUD recording isn’t going to be made available, you guys should at least remove the “Show HUD” check box on the matinee recording dialog, since that makes it look as if the feature is supported (and maybe the “Hide Hud” property on the object itself as well).