Matinee Create Movie Bug

Hey all. I’ve created a matinee scene and tried to creating a movie. I’ve added Play Matinee on Begin Play Node, if I press “OK” on matinee / create movie, client is opening and matinee not working and not rendering.

I’ve tried this situtation on 4.9, it’s okay.

Hello -

It looks like this is a regression and I have entered a report as UE-23651. In the meantime, I have found if your change the default Output Folder to a smaller folder path name then your matinee should render as expected.

Thank You

Eric Ketchum

I have the same issue but the path solution didn’t sort it.
What should I do? Thank you.

Try also changing the Name of the Output file, remember to keep it as short as possible and also make sure that you are using a very short folder path for the file path, C:\Temp with a file name Movie##.avi would be ideal until this issue can be corrected. I have not tested this yet, but you would probably want to avoid spaces and special characters.

Let me know -

Eric Ketchum

I also seem to have this issue with 4.10.1… The short file name seemed to work at first, but after a restart I am not getting any output other than the player start. What may be of note is that when when watching the folder thumbnails update (Windows 7 Pro) the correct camera image was being shown, but immediately overwritten with the player start view. This was rendering as a jpg sequence…

After restart to you check to ensure that the Short Folder Path was set the same?

Also this issue was not corrected in 4.10.1, it is still being actively worked on.

Thank You

Eric Ketchum

Hey Eric, yes the short folder path was set the same and I have since changed it. I have the folder path set as D:\h and the filename I have tried just with 1 letter and also for example r{frames} but with no luck.

Oddly, I can not seem to replicate the situation where it worked earlier in the evening. I’ve tried playing with the Additional Commands (leaving it blank as opposed to -PIEVIACONSOLE -nomovie) as well as all the other options, all to no avail. I have not yet done an aiv render… Next on the list!

EDIT: Today I managed to render out all the movie sequences I needed to. However, this was far from plain sailing. As I did not render a complete sequence, I rendered each camera one by one, matinee had to be closed, the project file saved and the director track deleted and recreated every time. For some reason doing anything other than this caused the movie to render either the previous camera even though it was no longer in the director track, or the player start.


If possible, can you share the project or a sample which demonstrates the problem you mention above. You can keep it private by sending a link to the following private message link:

Thank You

Eric Ketchum

Hey - We’ve found a potential issue in that the default output folder had changed from 4.9 → 4.10, but the file writers don’t necessarily create the folder when they try and write to it, which may be causing some movie captures to fail.

One solution in the mean-time would be to manually create the output directory yourself before running the capture.

I have problem vith matinee movie creation

gentoo linux amd64 (all latest), clang/llvm 3.6.2, unreal engine 4.10.2
gpu gtx780 x 2, cpu intel i7 ivy, 64 gb RAM.

Steps to reproduce

  • open new project
  • open new matenee
  • Create movie (why it store previous settings?)
  • i change 25fps, jpg, uncheck compression.
  • Capiture movie
  • Game start fine, i close player window open store directory and it EMPTY ((((

Hello Brothermechanic -

Can you please post this as a new Question?

Thank You

Eric Ketchum