Download

Matinee Capture Movie issue with animated skeletal mesh

Hi everyone,

I’m currently using Matinee in UE4 (version 4.13) to produce a short animated feature. I chose to use one level per shot so I don’t have to deal with tons of assets and other complexity. I also don’t have to bother with several cameras within the director’s camera group. Assets are done in Maya and exported in FBX. Everything works just find in the viewport when played through Matinee (I kept the Matinee Actor and didn’t convert it to sequence actor on purpose). Animations are played exactly as they supposed to do (same as what I have in Maya).

The weird thing comes when I render out a shot with the Render Movie exporter (when I hit the capture movie button). Wether I output sequence image or avi. Skeletal meshes (that was animated in Maya) are not located at their “proper location”, at least not at the same place as they are when played in the viewport through Matinee o_O Really weird!!

I already tried to:

  • Put all the assets under the matinee node in the outliner so everything would be relative to Matinee…
  • Trigger the Matinee player with Blueprint instead of having the “looping” and “Play on Level Load” boxes checked in the details panel of the Matinee Actor.

It has worked just once for an asset in a shot when I:

  • Put the animated object under a super parent with zero transforms and the re-exported from Maya + import animation option “Root Motion Root Lock” set to Anim First Frame

All other attempts to reproduce the fix on similar assets in the other shots failed.

I’m really stuck --’ If anybody has an idea I’m all ears :slight_smile:

Thank you for reading this to-long-message folks!