Matinee Camera is spinning

I am using UE4.6. I created a new matinee, camera group, key frame, and director group. From the 0.0 to 3 seconds I moved the camera horizontally a few feet. When I play it back the camera spins in a 360 degree pattern over and over.
I deleted the camera and matinee icon - started over again and again with the same results. Am I doing something wrong or is it a bug int the new release.

thanks,
Julian

Hey jlnsvfx,

So I ran a test to see if the Matinee camera actor rotates along a straight line like you mentioned. I was able to confirm what you were talking about, but there is a simple fix as well. There is a checkbox in the details panel when you click on your camera actor called, “Use Quat Interpolation.” Check this box and your problem should be resolved.

Here is some documentation on Matinee editing as well. It provides great information on how to edit tracks and where to find certain settings.

Matinee uses two different rotation interpolation schemes to rotate Actors between keyframes: Euler and Quaternion.

Euler - This is the default and works by interpolating the Yaw, Pitch and Roll of the Actor between the values at keyframes. This allows you to edit the 3 curves for orientation over time in the Curve Editor and control ease-in/ease-out between keyframes. It also supports winding - that is, if you rotate an object multiple times around, the keyframe will store the number of complete revolutions instead of throwing it away. This makes it easy to keyframe something like a screw going into a wall, and also gives you complete control over which direction an Actor takes when moving between two orientations.

Quaternion - This method of interpolation does not support winding, and is essentially linear between keyframes with no support for ease in/out. However, it is more robust and will always find the “shortest” route between two different orientations.

You can control which method is being used by toggling the Use Quat Interpolation setting from the Details panel.

Matinee Track Reference Doc

Cheers,

Andrew Hurley

Awesome that worked - thanks!!

No problem!

Just had the same problem today… many thanks!