Download

Matinee/Blueprint - Overlap = Hide Player?

Hey Everyon!
I tried creating an overlap event in Blueprint in which once the player overlaps the trigger; It hides the player from view until a Matinee cutscene is over, which then it will unhide the player and the player camera. I tried using hide actor and destroy actor on ALL the components of my player (Third person example) but it’s not hiding or removing my player from the game.

Is this a bug or am I doing this the wrong way?

Can you show us your blueprint setup? Also, did you check Hide Player in Matinee’s properties?

Just did a demo run and works fine if you /on actor begin overlap /Function play(reference matinee) start play on level load /looping is unchecked

This works great, I didn’t notice that at all! However, my blueprint isn’t at the start of the level; I’ve triggered it and it works perfectly, but is there any way to hide an actor in the cutscene during gameplay? For example, Player walks to ramp, I’ve got an animation in Matinee of the the player running around the loop, which is triggered by a volume. It is possible to hide the mesh thats in the Matinee until the Matinee has begun playing.

i dont know if this is of any help to you “add new visibility track” in matinee

Just check “Actor Hidden in Game” in the mesh’s details to hide the mesh. Then as Hamzter said, use a visibility track in Matinee to make the mesh appear whenever you want it to.

Thanks for the help everyone!