Download

Materials turned all black

Hello, I’ve encountered a troubling problem early on. :confused:

I was following Brick Whut’s tutorials and got to the one where you add the BP_waterplane or whatever the name is. Anyways, it didn’t show up and in the video, it says to load up The Island since I guess it loads a bunch of the assets as well.

So I saved my map since I had done some painting and sculpting. I had a landscape and dirt plane already. I probably used the Save As option and saved it in the map folder.

Anyways, after loading up the island, I opened my own map and everything had become black! I looked at the landscape materials to see if they had somehow not saved but it was set to the right ones (mat_theislandwithmask…) but the spherical icon was all black too! Where as it used to be dirt coloured?

I tried painting some different textures? (not sure if they are called textures) but that didn’t show up with any other colour either. I even tried to add the bp_waterplane and it was added. I could see it in the Scene Outlier tab as an actor but I couldn’t see the actual waterplane at all.

If anyone could help me out and point me in the right direction, it would be MUCH appreciated!

I even tried replacing the engine files from GitHub! I hope I don’t have to re-download the Ark editor…it’s too many jee-bees.

Cheers.

EDIT: So I figured out that it doesn’t have anything to do with the materials or textures. Rather, I somehow messed up my lighting! I suspect I might have pressed a button accidentally or changed some settings I didn’t mean to. Basically, what happens now is that when I choose the ‘Unlit’ option, I can actually see everything. It isn’t all black! But once I go back to ‘Lit’ or if I play the map within the editor, everything is very dark. I need to use a torch to be able to see anything. Does anyone have any clues as to how I can fix this?

Yesterday night, I tried deleting the materials that showed up as black and getting them to redownload but that didn’t work.

I have uninstalled it and will reinstall to see if that fixes the problem. It’s unfortunate that I have to attempt this since the dev kit is a ridiculously huge download.

Will post the result afterwards in case others run into the same problem.

Interesting info about the lighting causing this issue. This is good info for us to know about so we can pass the word along to others that may encounter this problem along the way. Please keep in mind that ARK and the Dev Kit are EA, and that we are basically breaking in the Dev Kit by catching all the bugs currently. It may be sometime still before we know about all these little nuances with Dev Kit, and resolutions to uncommon issues.

Also, general good rule of thumb is NEVER modify any core gamedata files. Always make duplicates.

PS: I have a feeling you somehow modified the world lighting to be very very dark. If you had fiddled with any lighting settings, try to retrace your steps and figure out where the problem occurred. I haven’t fiddled with lighting at all myself thus far, so I can’t really shine much light (no-pun intended lol) on the situation. Either that or you might of accidentally nuked your world lighting completely.

UPDATE: Try checking under world settings on your level, and/or under lighting. My educated guess says its somewhere around there.

  • Sinari

Heya, so I managed to re-download it all and gained some insight as to how I got myself into this situation.

The issue occurs when you change lighting modes from ‘Lit’ to ‘Unlit’ within the level window. They are the lighting options at the top left beside the Perspective options.

Once you have switched from Lit, going back to Lit will not properly display the lighting. Or perhaps it is properly displaying it at this point since we have no light sources yet (it just won’t be the same as what you started with).

Anyways, my current work around is to use stick with the ‘Unlit’ mode. I’ll try using ‘Lit’ again when I get to the tutorial regarding atmosphere and light sources.

Awesome, good job on finding out specifically what the cause was for you, that helps out the dev’s quite a bit generally speaking with reproducing it on their end.

I just attempted to reproduce this on my end, and no luck. But this was on TheIsland, switching back and forth between lit and unlit, not a custom map of my own making at all.

I’m wondering maybe if it could possibly be a GFX card issue? What’s your GPU? And also what’s your overall rig specs?

One last thing, this issue only happens on your own map you said? I think you may just simply be missing global light source(s) if that is the case. The lighting on TheIsland (global) is actually comprised of IBL and a few other things from my poking around, which mean’s it gets global light from a few different light sources (Obelisks actually provide a good deal of global light, etc).

I’m leaning towards this being a case of missing the global lighting source(s), but it is possible it could be a bug with your GPU. Just throwing some theories out there.

  • Sinari

It was a new level from scratch but creating the landscape using the Ark materials.

And yeah, the problem was that it was missing a light source. The confusion stems from the map looking lit right after creating the landscape! So when you navigate from the default light settings and back, it won’t look the same! Pretty silly and beginner mistake…

Hey, it happens to the best of us. We can be tired, and working on a mod late at night. Or we could be perfectly alert and just overlook something. No matter how smart we are, we all make mistakes, and it’s a part of learning things :smiley:

Your mistake has given others the chance to learn from this, and help others potentially in the future if they encounter this!

  • Sinari