Download

Materials not showing in viewport

Hi everyone

I’m having a situation here and since i’m just starting with UE maybe it’s a simple issue.

I imported just the geometry from Max using Datasmith, so i can crete my materials directly into the engine. So far i created a few master/instance materials but when i drag/apply the material to any geometry inside the scene, it appears in the slot but is not showing on the viewport. They keep the appearance of the WoldGridMaterial default. Looks like the viewport is “Material locked”.

I also tried to apply the material directly in the asset window, with no success.

Viewport is currently in lit mode with simple lighting that is supposed to show all the materials.

Can anyone help on this problem?

Thanks in advance!

You may need a reflection capture actor next to your metal tray. Reduce the radius and build reflection captures from the build menu if it doesn’t make a difference.

In Max, have you UV unwrapped your mesh and assigned a basic material (like just a base color)? Materials have to me assigned in Max before been replaced in UE.

Hi S-Dot

This happens even with an opaque material i made, it’s not just metals.

Strange thing is, when i imported a surface texture from Bridge, worked perfectly…

Hey E487,

Yes, this is a full scene i worked on Corona, so every object has some kind of mapping, maybe not the one in the example (because there is no need for mapping for chrome-like materials in Corona), but the problem extends for all the other objects in the entire scene, walls, floor, wooden ceiling, i just don’t understand…

But thanks for the tips! By the way, i exported everything using DataSmith, so theoretically all the mapping should have came along right?

Yes, it should have. If your materials are ok in Max, sorry, I don’t know what could be the problem. Try using non-Corona materials, like Standard Material.

Maybe something within your material? Can you show us how the material is set up?

Hi guys

Sorry about the delay, was away for a while.

Haven’t had any time to meddle with Unreal these past weeks, but thanks a lot for your thoughts.

Guess i’ll just start over and see if a blank project may solve this, then i post it here.

Thanks again!