Download

Materials dont show up on my surfaces from Megascans Bridge

Having a very frustrating time with bridge right now.
Installed bridge
Installed plugin for UE4
exported surface texture from bridge to UE4 and it comes in beautifully. Material and textures
Drop the material on my mesh and it just shows checkerboard.
Drop a substance material on and it shows up fine… drop the megascans material back on and it shows checkerboard.

What am i missing?

thanks!

I’d really like to know the answer to this as well. I figured out that it’s not Megascans Livelink, if you drop a cube into your scene it picks up the applied texture no problems.

It’s got something to do with the Datasmith import.

Anyone have any idea as to why this would happen?

Generally the checkerboard means the material didn’t compile, but that could be for any number of reasons. If you open up the material instance that you’re trying to use, you should see some red text in the preview viewport.

I’m gonna guess and say it’s probably due to a texture not using the correct settings that the material is wanting, like RMA textures being marked as Masks, even though it’s no different than DXT1 with sRGB unchecked manually.

I am having the exact same problem. anyone who give us any solution regarding to this issue would be the best.

same problem here… ue 4.23

Do you have the big green Megeascan icon in the menu bar?

If you import correctly from the bridge then a master material is created and the actual material you used is created as an “instanced” material from the parent. A bit touchy at first but does work.

{I’m using the latest unreal 4.23 and bridge version) I too have the same issue…texture gets exported successfully into unreal and event the material created is fine. but when I try to drag onto any object it shows the default material only. And it works only if I applied the megascan material to the object inside a static mesh window. if anyone has a solution please share.

#megascan #quixel #material #probelm

Any solution for this one? I have the exact same issue. The problem is that if I drag drop the material to the basic UE4 geometry, the material shown perfectly, but when I drag drop the material to the mesh that I have imported through datasmith, the surface turned into grey checkerbox.

Hello guys… I think that I found a solution:
-You need to uncheck the “Crack Free Displacement” option located on Tesselation tab in the “material result node” (sorry, I’m quite new in UE4 and don’t know the right name!) in master material of the surface that you want to use! After uncheck, just save it!

Try to Follow the image below!!

PS: It’s my first post here to! Sorry my possible mystakes!

Thank you. I’m new to the editor as well and I have no idea what “**Crack Free Displacement” **but disabling it worked.

If you *want *crack free displacement, you can edit the asset, then select build settings in the details pane, click “Build Adjacency Buffer”, apply changes, save. Apparently these aren’t built by default with the importer.