Material to Texture (Export to Disk)

Edit: How can I export the RenderTarget as a Texture (TGA) out of UE using blueprint?

I’m trying to export BaseColor Texture out of my Procedural Material by creating a dynamic Render Target 2D and then Export Render Target.

But I can’t open the files in 3rd party applications like Krita/photoshop or even view them,


I assume it is because I’m exporting Render Target Data but not the Texture.


But I can import it back in UE as Texture.

So then I changed my Render to Texture function to this by creating a Texture 2D object and Convert Render Target to Texture2D and then Export Texture 2D.

But now I can’t even open the file in any 3rd party application, and when I import it into UE, surprisingly, it Creates Texture Cube! I can’t make sense out of it.


Then I try replacing Export Texture 2D with Export to Disk.

But it throws errors.

LogTexture: Display: Building textures: Texture2D_0 (AutoDXT, 1024X1024)
LogScript: Error: Script Msg: Invalid texture supplied.
LogScript: Error: Script call stack:
    MaterialBreaker_C.Render to Texture

I even try changing it to Render Target Create Static Texture Editor Only using Export Texture 2D and Export to Disk.

Both results are the same as Texture 2D results, only it does create Texture in UE content editor, but nothing on the disk.

I’m wondering if I’m doing something wrong or there is another solution to this?


I think this could be helpful:


THANK YOU @Jokerminator !!!
I read over OPs post and I had done ~2/3rd of what they tried before coming here.
13:20-15:00 was all i needed from that video to solve my problem.
(for others seeing/reading this, Sam uses the construction script bc he dose not want to play or simulate. In my situation I trigger the ‘bake’ function at runtime from procedural drawn art, so i do not want the construction script. He has to move the item to trigger the construction while PIE).

This is another case of , how few even know about the Engine content artist tools sitting right there?! Amazing!! Thanks again!

PS: this should be marked solved @BernardRouhi - if you have not yet got it solved from this above video pls let me know and we can try and work the solution on this post, but its many months later now…hope it worked for you as well!