Download

Material/Texture issue

Hello all!

I have a small issue which i want to get solved.

Everytime i drag in a Static Mesh the material on it won’t load. I have to go into the Material screen (Where it gives me an error at the textures) and then edit the texture so it works.

I have imported the packages i use properly. I have no clue how to solve this. hopefully you guys have some more information

Thanks!

-are you sure that you have assigned the material in your static mesh editor?
-which kind of error do you get in your material?
-what exactly do you have to edit?
-have you moved the content from another project into your own one? :slight_smile:

Hey there Fighter,

I am working on a game with a few friends. One of the friends bought “The bunker Pack” For example. He shared the folder to me and i placed it into the content folder of the project. At the start this worked fine but lately everytime i drag something in this happens:

http://puu.sh/hqNLZ/1228346e41.jpg

As you can see it won’t load the Material at all. I have to do this manually.
Once i have chosen the material i want, the texture on the material won’t pop up correctly so when i go to the editor i get this:
http://puu.sh/hqNSr/8557eec280.png
Here i have to edit the textures so it will show properly,

I have used this package for a other project in the past, and i used it the same way as i do now. However on my older project all the materials loaded in directly when i placed the Static Mesh.

Also worth to note that one friend of mine have the same issue and the other one not at all.

Seems like all the references got lost (mostly happens when you move folders outside of the editor) → that’s how you move stuff from one project to another one: https://www.youtube.com/watch?v=GsA5SlMqsvg
So you will either have to reconnect everything (materials, textures,…) or readd the package :slight_smile:

Yeah, i have tried everything pretty much. Doing the exact same thing as the video aswell, no results. So the only option for me then is to reconnect everything manually?

Hmm, then you will have to reconnect everything again. :frowning:
But how do you guys share your folders? (perforce, snv,…)

He takes the root folder of the package from the vault, put it on Copy and i’ll download it from there. After that i drag it into the project folder.

I dont know it that package is downloadable as a project or just as content which can be added to a project, but do it like that:

  1. he should add the content to a project
  2. he sends you the entire content folder
  3. add it to your own project (make sure to copy it into the root of your project folder -> so where you can already see a content folder - just overwrite it)
  4. now it should work :slight_smile:

Will try it out this way, Thanks :slight_smile: Will keep you updated!

Hey Fighter! just an update. Followed your steps and now it works fine!

Thanks a lot for all the help, it’s greatly appreciated!