Material shows wrongly

I’m having a problem with a model in Unreal that when i assign a Material, the material only shows a plain color with some ambient occlusion shadows from the model.
The mesh has two materials and the other material works completely fine. The UVs are right and the second material that it’s supposed to be showing works fine also when i put it in other models. Also, when i try put other materials into the mesh the same problem happens, plain color with shadows.

I share two screenshots of the problem and also one where i put the material that doesn’t work in the other part of the model to show that it’s fine and i put another material in the place where it doesn’t work to show that the problem it’s still there.

Anyone knows what’s the problem?
Thank you

The only cause I’ve ever seen of this is the texture being massively zoomed in.

I know you said the UVs are ok, but I would try re-scaling them for that area.

I also thought it could be that, and I tried re-scaling the UVs and also rescaling the material in Unreal with TextCoord, but both don’t work.
I really don’t know what could be the problem. It seems to be something with the mesh, but in 3Ds Max and Maya the texture shows correctly, so I don’t know if it’s that I did something wrong when exporting or importing or another thing

Yes, weird.

If you want to PM me model and textures, I’ll take a look… That’s all I can say without further info.

Here you have the model and the textures, if you see anything weird let me know.
SM_columnbrokenB.fbx (71.5 KB)
Column textures:

Break part textures:

Yes, I see it.

You didn’t map the UVs for the broken part

Notice that what you were showing earlier was the lightmap. The UVs are on channel 0.

Also the pillar is TINY :slight_smile: I think it needs to be scaled by 100:

I take that back, something I did. I scaled it by 2 only, in fact. I also removed the second UV map.

Okay, thank you!!
Finally solved it.
Like you said the UV map was wrong. I don’t know how but I managed to create 2 UV maps for the same mesh and although the second one had the UVs correctly (thar it was the one that Unreal showed as UV channel 1), the other one Unreal imported it as the main one and didn’t had the UVs of broken part.
I removed this las channel in Maya and now it works.

Thank you so much for helping me :blush: :blush:

1 Like