Material problem

Hi. I made a tree using a Blender addon and used a texture from

In Blender it seems okay but in UE4 materials wont show up like this:

Here is the texture I used:

Did you UV unwrap the tree? If you can show us a screenshot from Blender that might be useful.

Also, what Blender add-on was this?

I can not UV map this because this addon (mtree for blender 2.8) uses curves to create trees not vertices. So I tried to add material by using UE4 and results are the same. Here is the Blender screenshot:

Okay, I’ll try your advice and I will comment back. By the way, it’s mine texture. Not the addon’s.

I thought mTree comes with materials/textures. From your Blender screenshot, it looks like the tree does have some sort of material. If this is the case, make sure you are exporting the tree with the materials. You can probably switch the materials once the tree has been imported to UE4.

Another alternative is to convert the tree to a mesh in Blender. Then use Smart UV Unwrap.

I’m not very familiar with the mTree pipeline, but that is the approach I would use for starters.

Blender has a “steep learning curve”. But it’s totally worth it. I don’t use the material editor in Blender now that I’m on UE4. Either way works fine though.

Plus I wouldn’t recommend learning Blender with tree models. :slight_smile:

Problem solved! Tried to convert curve to mesh and worked like a charm. But I applied the texture by UE4 not Blender. If you are not an artist, Blender and any other applications sucks for you.

Thanks for your help!