Material Preview works very slow

Good day,

I’ve faced with such an issue: Materials preview loading takes 10-20 seconds and sometimes 1-2 minutes. Even if I place just a colour and nothing else it still takes a lot of time to update the preview.

As I see in the Web, this is not a common problem and I have found only one solution: up the priority of the ShaderCompiler.exe in “Task Manager”. I have tried to use this stuff: FixShaderCompilerW32


But this did not work for me.

I came to Unreal Engine from 4.24.3 version and immediately faced with this problem.
I faced with the same trouble in the clean 4.25.0 version – I even installed it on SSD M.2, but the result is the same.

Is there any way how I can fix it? If anyone knows how to solve this slow loading issue, kindly share the solution.

Thank you for your time!

My PC spec:

Intel Core i5 @ 2.80GHz

16,0 GB RAM

NVIDIA GeForce GTX 1060 6GB (MSI)

Windows 10, x64, Home

When you make and/ or changes any materials, when you press apply, then Unreal start to apply the material to the object’s and compile the materials.
They compiling is what taking long time, and it is no way to change/ fix it.
I don’t think that compiling using hardware acceleration.

I hope that this help you.

Thank you for your reply.

Yeah, I know about compiling and understood that this process can take a long time. But my question was about a preview window.

Please take a look this screencast I’ve made:

In the first 40-50 secs, Preview Window (in top left corner) was very slow – it was slow because of Compiling Shaders process, I guess. But then, when all shaders finish compiling, Preview Window became updates in 5-10 secs. And this is only colour. If I add textures, it can take much more time. As well as saving changes take up to two minutes.

I afraid, here is something more than weak PC specs. I think so because there are several topics in the Web where people faced exactly the same problem, but they have better PC: i7 CPU, 1080ti GPU and 32 Gb RAM.

I tend to think that the problem is in the settings, perhaps I can make optimization. I just do not know how and would like to find this info.

I don’t know how to fix this, it is a software working in the background slowing down Unreal.

Try to use a different version of Unreal and see if it is as slow in and older version.

Unfortunately for me, I’ve faced with the same issue on three versions:

I running UE 4.24.3 and 4.22.3 at HDD and 4.25.0 I running on SSD M.2 (Samsung SSD 970 PRO 512GB)

Use task manager and give Unreal Engine 4 And all the drives from Unreal higher priority.

If that don’t work try to run Unreal as an administrator.

Try to update all your drives, and make share that your anti-virus don’t scan when you make materials.

Do you run Unreal Engine on an external hard drive?

Thank you for your suggestion! I will try it. Could you give me an advice, how I can recognize all the drivers from Unreal and be sure that I did not miss some of them? Will their names have “UE” or “Unreal” kind of text?

Open task manager and click on the UE4Editor drop down when you start to create a new material and select right click on one of the UE4 icons and go to property.

then right click them and go to set priory, then set it to high.

I hope this will help you




Thank you for the clear description of your suggestion. However, I have already tested this way: I did it manually from the Task Manager (just like you suggested) and automatically – with “FixShaderCompilerW32”. In both cases, I get the same result.

What do you think, is there some settings inside Unreal Engine that can affect to Preview Window work speed?

Open Nvidia Control Panel and under 3D settings, is Unreal Engine 4 added?


Also try to turn the power setting to High Performance, maybe it will speed up Unreal Engine 4

Do you mean this?

Sorry for not answering sooner.

Yes, you can try to change some settings in the Nvidia Control Panel. next set you power settings to high performance.
And also turn of the real-time in Unreal engine 4.

Ah, there is no problem. Thank you for your efforts to solve this issue!

I have tried to choose “Performance” in Nvidia Control Panel, as well as disabled Real-Time for the Viewport and Thumbnails. However, these actions did not help.

I feel, there is some optimization problem and usual edits will no work. I guess, the problem is in the code or so.

Really do not know where I can find the solution. I think, even in my CPU 10-15 secs for updating colour is a too long time.

i found the way its because of integrated graphics ,disable it in devise manager,right click and disable it


Thank you for your reply! I need to clarify, I have no integrated graphics.
However, I have solved this problem by reinstalling Windows: previously I was at the Home version, then I’ve installed Pro. I’ve heard about restrictions in Home, this OS downgrading PC performance – Home version intended for a non-resource intensive soft, like MS Office and cannot work correctly with graphic software, like Unreal.