Material Not Doing Same Thing In Game As It Is In Blueprint Component Viewport.

My blueprint is not reproducing the effect in the game as it is when i do inside the blueprint it self.
Here in the blueprint view port tab, i am increasing the radius of a sphere which is setting a material of a block based on location/radius of the sphere. And as you can see as i increase the radius, the material becomes visible on the block. However when i do this in game, it is just always not visible.


I tried a few ways to go from radius=0 to radius=255(ish, big enough to make the whole material visible on the mesh), but couldnt get it to transition at all, the material would always be not visible. So i thought i did something wrong with my blueprint increasing the radius, but then i just set the radius to a large value (255) to see if it would be visible straight away as it appears it would be in the viewport tab inside the blueprint, but it was not.

Here is what i had for the blueprint radius increasing thing. (or my attempt at it, i am sure i did it wrong anyway)

and here is what i see in the game. ( the material inside the red bit should be visible)

Here is some information if it helps.

The material itself: ( I tried learning from these tutorials and, which worked fine in a separate project, then i copied the material over to this project and tried to make a few adaptions but it is proving unsuccessful so far.

The event tick inside my blueprint:

Construction script of the blueprint:

Material parameter collection:

If anyone could help with either the lerping from small to large radius, and the problem with the material never being visible (working inside blueprint, but not in game) issue, it would be greatly appreciated.

Sorry to bump but i still have not resolved this issue, and it is really delaying progress. If anyone could help it would be greatly appreciated. Thanks.